Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por juacas el Jue 2 Sep 2010 - 11:20

Hola a todos,

desde el principio no he podido recibir ni la televisión en directo ni las grabaciones mediante el plugin streamdev-server.

Los síntomas son los siguientes:

- Se conecta y empieza a llenar el buffer (tarda unos 10 segundos)
- Comienza la reproducción y reproduce menos de un segundo, se corta y vuelve a comenzar cargar el buffer.

He comprobado que no es por la velocidad de la Wifi porque ocurre lo mismo si conecto con cable directamente al router.

El Log de VLC es el siguiente

Código:

main debug: Buffering 41%
packetizer_mpegvideo debug: waiting for sequence start
packetizer_mpegvideo debug: size 720x576 fps=25.000
main debug: Buffering 43%
main debug: no usable vout present, spawning one
main debug: looking for text renderer module: 2 candidates
freetype debug: Building font databases.
main debug: Buffering 45%
freetype debug: Took 16000 microseconds
freetype debug: Using Arial as font from file C:/Windows/fonts/arial.ttf
freetype debug: using fontsize: 2
main debug: using text renderer module "freetype"
main debug: TIMER module_need() : 58.000 ms - Total 58.000 ms / 1 intvls (Avg 58.000 ms)
main debug: looking for video filter2 module: 18 candidates
swscale debug: 32x32 chroma: YUVA -> 16x16 chroma: YUVA with scaling using Bicubic (good quality)
main debug: using video filter2 module "swscale"
main debug: TIMER module_need() : 2.000 ms - Total 2.000 ms / 1 intvls (Avg 2.000 ms)
main debug: looking for video filter2 module: 18 candidates
yuvp debug: YUVP to YUVA converter
main debug: using video filter2 module "yuvp"
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: window size: 1024x576
main debug: Deinterlacing available
main debug: deinterlace 0, mode blend, is_needed 0
main debug: looking for video output module: 1 candidate
vout_wrapper debug: Opening vout display wrapper
main debug: looking for vout display module: 8 candidates
main debug: Buffering 47%
main debug: Buffering 50%
direct3d debug: creating Vout EventThread
direct3d debug: DirectXCreateWindow
main debug: looking for vout window hwnd module: 3 candidates
qt4 debug: requesting video...
qt4 debug: Video was requested 0, 0
main debug: using vout window hwnd module "qt4"
main debug: TIMER module_need() : 37.000 ms - Total 37.000 ms / 1 intvls (Avg 37.000 ms)
direct3d debug: created video sub-window
direct3d debug: Vout EventThread running
direct3d debug: disabling screen saver
main debug: VoutDisplayEvent 'resize' 1040x614 window
direct3d warning: trying surface pixel format: YV12
direct3d debug: selected surface pixel format is YV12
direct3d debug: Direct3D scene created successfully
direct3d debug: Direct3D device adapter successfully initialized
main debug: using vout display module "direct3d"
main debug: TIMER module_need() : 282.000 ms - Total 282.000 ms / 1 intvls (Avg 282.000 ms)
main debug: using video output module "vout_wrapper"
main debug: TIMER module_need() : 282.000 ms - Total 282.000 ms / 1 intvls (Avg 282.000 ms)
main debug: got 1 direct buffer(s)
main debug: pic render sz 720x576, of (0,0), vsz 720x576, 4cc I420, sar 64:45, msk r0x0 g0x0 b0x0
main debug: pic in sz 720x576, of (0,0), vsz 720x576, 4cc I420, sar 64:45, msk r0x0 g0x0 b0x0
main debug: pic out sz 720x576, of (0,0), vsz 720x576, 4cc I420, sar 64:45, msk r0x0 g0x0 b0x0
main debug: direct render, mapping render pictures 0-23 to system pictures 1-24
main debug: VoutDisplayEvent 'resize' 1024x576 window
avcodec debug: using direct rendering
main debug: End of video preroll
main debug: Received first picture
freetype debug: using fontsize: 36
main debug: looking for video blending module: 1 candidate
blend debug: chroma: YUVA -> I420
main debug: using video blending module "blend"
main debug: TIMER module_need() : 0.000 ms - Total 0.000 ms / 1 intvls (Avg 0.000 ms)
main debug: Post-processing available
main debug: Detected interlaced video
main debug: deinterlace 0, mode blend, is_needed 1
main warning: vlc_object_find_name(postproc) is not safe!
main debug: Buffering 52%
main debug: Buffering 66%
main debug: Buffering 97%
main debug: Stream buffering done (1200 ms in 12308 ms)
main debug: Decoder buffering done in 0 ms
main error: ES_OUT_SET_(GROUP_)PCR  is called too late (jitter of 9907 ms ignored)
main debug: ES_OUT_RESET_PCR called
main debug: End of audio preroll
main debug: Buffering 0%
main debug: Buffering 2%
main debug: Buffering 4%
main debug: Buffering 6%
main debug: Buffering 8%


La clave, creo que está en que aparece un error en la secuencia y se reinicia el buffer:

Código:
main debug: Buffering 97%
main debug: Stream buffering done (1200 ms in 12308 ms)
main debug: Decoder buffering done in 0 ms
main error: ES_OUT_SET_(GROUP_)PCR  is called too late (jitter of 9907 ms ignored)
main debug: ES_OUT_RESET_PCR called
main debug: End of audio preroll
main debug: Buffering 0%

pero no he encontrado explicación.

Con MPlayer ocurre lo mismo.

¿alguien sufre el mismo problema?

Un saludo a todos.

juacas

Cantidad de envíos : 20
Fecha de inscripción : 19/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por bittor el Vie 3 Sep 2010 - 9:00

¿has probado con el interfaz web?
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por juacas el Vie 3 Sep 2010 - 21:21

Sí. el efecto es idéntico (lo cual es razonable puesto que el plugin embebido usa el mismo núcleo que el cliente VLC).

juacas

Cantidad de envíos : 20
Fecha de inscripción : 19/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por juacas el Mar 7 Sep 2010 - 7:45

Creo que mi problema de este hilo, reside en la velocidad de transferencia por red. Lo he medido mediante una transferencia FTP y no llega a más de ¡¡¡ 80kB/s !! tanto por Wifi como por Ethernet, tanto entre mi ordenador y el M7x0 como descargando de Internet.

Dado que he leído que vosotros obtenéis con facilidad 10 veces más velocidad, debo asumir que mi equipo tiene algún tipo de avería, porque no conozco ningún parámetro de configuración que pueda mejorar esto. Sad

Si alguien ha sufrido el mismo problema y lo ha solucionado, le agradecería mucho su aportación.

juacas

Cantidad de envíos : 20
Fecha de inscripción : 19/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por juacas el Mar 7 Sep 2010 - 8:44

Me lo soluciono yo mismo.Avergonzado

Parece que había un problema en el latiguillo Ethernet.Avergonzado He cambiado el antiguo por uno nuevo y todo va como se esperaba.

Dejo aquí la solución para que conste que un cable en mal estado puede crear comportamientos desconcertantes.

Saludos. Very Happy

juacas

Cantidad de envíos : 20
Fecha de inscripción : 19/08/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas para recibir flujo streamdev en PC con VLC y MPlayer

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.