Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Ver el tema anterior Ver el tema siguiente Ir abajo

Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Lun 27 Sep 2010 - 19:04

Pues después de tener algunos problemas con el NFS (tenia una versión antigua del VDR, no recuerdo cual), hoy he probado de instalar la versión: VDR-NG-EM 0.6 revisión 833 (que casualmente salio ayer) pero no consigo que funcione.

Dispositivo: M740
Con el generador de windows he generado el WSW (6210 KB).
Hago lo del menú de los 4 enchufados.
Hago el 'reset factory'.
Hago el load del nuevo firm.
Sale lo de cargando, y cuando acaba, la televisión hace como unos "flashes" y se queda en negro.

La luz del siemens se queda haciendo intermitencias. Y haga lo que haga no responde. Ni se abre ni se cierra, ni sale el menú, ni nada de nada.

Lo he repetido varias veces y siempre me sale lo mismo.

Aquí os pongo el resultado de: firmware-builder-debug.cmd (que da algunos errores).
Código:
C:\Siemens>firmware-builder-debug.cmd

C:\Siemens>rem -*- coding:cp850-dos -*-

C:\Siemens>rem -*- coding:cp850-dos -*-
Delete old files
Download orig firmware.
Unpack orig firmware.
Archive:  downloads\Gigaset_M740_AV_V_2.4.exe
  inflating: downloads/2.4_t.wsw
Download o7o-flasher.
Download m7x0-kernel-m740_pro.
Download list file.
Download rootfs_dir_m740_pro.
Unpack m7x0-rootfs.
Grab orig cramfs. This may take a while....
786432+0 records in
786432+0 records out
6291456 bytes (6.3 MB) copied, 4.535 s, 1.4 MB/s
Swapping orig cramfs.
Filesystem is big endian, will be converted to little endian.
Filesystem contains 893 files.
CRC: 0x2d47a78b
Extract orig rootfs files.
Copy orig blobby modules with mips-linux-uclibc-objcopy.
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
tos.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_rtos.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
ios.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_bios.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
sd.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_osd.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
v.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_av.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
eletext.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_teletext.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\emma_
b.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\emma_fb.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\iic_i
t.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\iic_int.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\lirc_
ev_s.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\lirc_dev_s.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\dvbde
.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\dvbdev.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\pic16
73.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\pic16f73.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\pds50
2cl.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\pds5002cl.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\tda10
46.o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\tda10046.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\tuner
o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\tuner.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\demux
o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\demux.o' is empty
bin/mips-linux-uclibc-objcopy: 'temp\unpacked_m740\lib\modules\2.4.21-xfs\video
o': No such file
bin/mips-linux-uclibc-objcopy: error: the input file 'temp\unpacked_m740\lib\mo
ules\2.4.21-xfs\video.o' is empty
.
Setting system type in firmware: M740AV
Setting language in firmware:
English
setup.conf
LC_ALL
help plugin
webif.conf
Generating SquashFS image
Duplicate device table entry '/etc' in line  292
Duplicate device table entry '/lib' in line  322
Duplicate device table entry '/lib/modules' in line  344
Duplicate device table entry '/lib/modules/2.4.21-xfs' in line  345
Duplicate device table entry '/etc' in line  387
Duplicate device table entry '/etc' in line  426
Duplicate device table entry '/usr' in line  447
Duplicate device table entry '/usr/sbin' in line  448
Duplicate device table entry '/usr/bin' in line  449
Duplicate device table entry '/sbin' in line  450
Duplicate device table entry '/etc' in line  451
Duplicate device table entry '/etc/webif' in line  452
Duplicate device table entry '/bin' in line  474
Duplicate device table entry '/etc' in line  705
Duplicate device table entry '/etc/vdr' in line  706
Parallel mksquashfs: Using 2 processors
Creating big endian 3.0 filesystem on temp\VDR-NG-EM-pro-firmware.be.img, block
size 65536.

Big endian filesystem, data block size 65536, compressed data, uncompressed met
data, no fragments
Filesystem size 5416.66 Kbytes (5.29 Mbytes)
        39.75% of uncompressed filesystem size (13625.67 Kbytes)
Inode table size 37278 bytes (36.40 Kbytes)
        100.00% of uncompressed inode table size (37278 bytes)
Directory table size 18744 bytes (18.30 Kbytes)
        100.00% of uncompressed directory table size (18744 bytes)
Number of duplicate files found 15
Number of inodes 1506
Number of files 362
Number of symbolic links  182
Number of device nodes 889
Number of fifo nodes 1
Number of socket nodes 0
Number of directories 72
Number of uids 1
        unknown (0)
Number of gids 0
Generating JFFS2 image
temp\jffs2-m740_without_marker.img
bin\jffs2_marker.bin
        1 archivos copiados.
Build final vdr firmware as wsw for m740.
Done.

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Mar 28 Sep 2010 - 8:48

El error es debido a que no encuentra los drivers de Siemens y por lo tanto genera un firmware sin estos drivers (que son fundamentales para que funcione el TDT) y aunque arranca no ves nada por pantalla, aunque pienso que podrás acceder a él por telnet o ftp si no se ha quedado enganchado intentando cargar unos drivers que no existen.
Mira a ver si en temp\unpacked_m740 tienes algo o está vacío.
¿qué versión de Windows estás usando?
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Mar 28 Sep 2010 - 10:26

Pues tengo:
Windows XP SP3.
Extraido en carpeta: C:\siemens\

Contenido de la carpeta downloads
2.4_t.wsw (12802K)
file_tab.rootfs_dir_m740_lite.lst (27K)
Gigaset_M740_AV_V_2.4.exe (10316K)
o7o_flasher (456K)
rootfs_dir_m740_lite.tgz (3567K)
siemens-linux-kernel-m740_lite.img (601K)

Contenido de la carpeta temp:
rootfs_dir_m740_lite (directorio, llen)
unpacked_m740 (directorio, VACIO)
2.4_t.wsw_orig_fw.be.cram (6144k)
2.4_t.wsw_orig_fw.le.cram (6144k)

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Mar 28 Sep 2010 - 16:43

Pues parece que lo único que está mal es que el directorio temp\unpacked_m740 está vacío.

Prueba a borrar solo el subdirectorio temp\unpacked_m740 y ejecuta esto desde el directorio donde esta el archivo "firmware-builder-debug.cmd":
Código:
bin\cramfsck.exe -r -x temp\unpacked_m740 temp\2.4_t.wsw_orig_fw.le.cram 2> log.txt

Se te habrá creado un archivo log.txt con unos cuantos errores de este tipo:
bin/cramfsck: crc error
warning: cannot generate special file temp\unpacked_m740/dev/avswitch as user.
warning: cannot generate special file temp\unpacked_m740/dev/console as user.

Eso es normal, pero mira a ver si ahora tienes algo en temp\unpacked_m740 o hay algún error en el log distinto (lo subes aquí).

Tomo nota para la próxima versión que se genere un log con todos los datos de generación para resolver mejor este tipo de errores.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Mar 28 Sep 2010 - 16:46

Se crea la carpeta, pers sigue vacia la carpeta unpacked_m740 :-(

Aquí tienes el log:
Código:
cygwin warning:
  MS-DOS style path detected: temp\2.4_t.wsw_orig_fw.le.cram
  Preferred POSIX equivalent is: temp/2.4_t.wsw_orig_fw.le.cram
  CYGWIN environment variable option "nodosfilewarning" turns off this warning.
  Consult the user's guide for more details about POSIX paths:
    http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
warning: file extends past end of filesystem
bin/cramfsck: crc error
bin/cramfsck: utime failed: temp\unpacked_m740: Invalid argument

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Mar 28 Sep 2010 - 17:43

Vaya error más raro.

Parece que no puede leer o establecer la fecha del archivo o directorio.

¿estás identificado con un usuario con permisos de administrador?
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Mar 28 Sep 2010 - 17:49

Si, estoy como administrador.

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Mar 28 Sep 2010 - 19:39

Weno, ha probado en otro PC (WIn XP+SP3) .... y ha funcionado a la primera lol!

Si quieres que haga alguna prueba en el PC que no funciona, lo dices :-)

Adéu !

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Miér 29 Sep 2010 - 9:23

Me alegro de que al final te haya funcionado, la verdad es que es un error muy raro que no había visto nunca y no sé a que se debe, puede ser un parche concreto de Microsoft, antivirus, un bug del propio cygwin, etc.

Si no te importa, en cuanto pueda (una semana o así) preparo un nuevo cramfsck con el último cygwin que se salte ese error del utime, a ver si así descomprime el contenido.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Miér 29 Sep 2010 - 11:43

Si, ningun problema :-)

Adéu !

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Jue 30 Sep 2010 - 9:00

Ya he modificado el cramfsck para que no se pare con el error del utime y compilado con el último cygwin.

Link de descarga.

- Descomprimelo en un nuevo directorio.
- Copia a ese nuevo directorio el archivo que tenías en temp\2.4_t.wsw_orig_fw.le.cram con ese mismo nombre.
- Ejecuta unpack.bat
- Mira a ver si hay algo en el directorio unpacked_m740 y si no hay nada mira el log.txt.

En la primera línea del log tendría que salir "2.4_t.wsw_orig_fw.le.cram: OK", indicando que el verificación md5 es correcta.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Jue 30 Sep 2010 - 11:47

bittor escribió:Ya he modificado el cramfsck para que no se pare con el error del utime y compilado con el último cygwin.

Voy :-)

bittor escribió:- Copia a ese nuevo directorio el archivo que tenías en temp\2.4_t.wsw_orig_fw.le.cram con ese mismo nombre.

MD5 ok.

bittor escribió:- Ejecuta unpack.bat
- Mira a ver si hay algo en el directorio unpacked_m740 y si no hay nada mira el log.txt.

El directorio està lleno !!
14.508.706 bytes, 491 archivos, 65 carpetas.

El log tambien està "lleno", 763 lineas de wawnigs i errores.

Lo adjunto por si hace falta.

Adiós !
Archivos
log.txt No tienes los permisos para descargar los archivos.(47 KB) Descargado 4 veces

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por bittor el Jue 30 Sep 2010 - 19:21

Pues parece que lo ha hecho bien.

He creado un nuevo builder para Windows añadiendo este cambio y recompilando todos los binarios usando el último cygwin 1.7.7-1 y de paso he hecho que siempre se genere un log y así será más sencillo detectar cualquier tipo de error.

No he probado a instalar el firmware generado, pero todo apunta a que es correcto.

Sería bueno que lo probaras en el equipo que te fallaba y así damos por solucionado este error para que no le pase a nadie más.

Link de descarga del nuevo builder.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Jue 30 Sep 2010 - 23:48

Hasta sabado o domingo no lo podré provar, que no estoy en casa.

Tant pronto pueda lo pruebo y te aviso !

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Petiso el Dom 17 Oct 2010 - 12:45

Eis, que se me había olvidado!

Weno, he probado el nuevo builder y ha funcionado bien: la carpeta unpacked_m740 ya no esta vacía.

Eso si, el firmware no lo he probado.

Adios!

Petiso

Cantidad de envíos : 11
Fecha de inscripción : 27/09/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Anacleto el Sáb 12 Mar 2011 - 13:09

Hola.
Comentar que hoy me he puesto a instalar el firmware 0.6 (tenía el 0.5, y como me funcionaba tan bien, por vaguería no me he puesto hasta hoy).

Bueno, pues lo he hecho desde windows, porque nunca he conseguido compilar desde mi ubuntu de 64bits., y utilizando el builder que aparece en el mensaje principal del 0.6. He tenido problemas muy parecidos a los de Petiso, el m740 se quedaba con la pantalla negra y parpadeando.

Con el builder nuevo que ha puesto bittor en este hilo, el firmware se ha generado bien, es más grande, y el m740 ha arrancado perfectamente. Gracias bittor! (por cierto no he visto el log, porque el builder no tiene el .cmd de debug)

Aprovecho para dar las gracias por el estupendo trabajo a todos los que habéis contribuído en el VDR-NG-EM.
Aplauso

Anacleto

Cantidad de envíos : 12
Fecha de inscripción : 28/06/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Firmware no carga (VDR-NG-EM 0.6 revisión 833)

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.