Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



es usable el trunk?

Página 2 de 6. Precedente  1, 2, 3, 4, 5, 6  Siguiente

Ver el tema anterior Ver el tema siguiente Ir abajo

Re: es usable el trunk?

Mensaje por papaloukas el Dom 4 Sep 2011 - 10:59

Al hacer un make de la versión trunk da un error en la descarga del fichero binutils-2.21.tar.bz2. Descargando manualmente la version
binutils-2.21.1.tar.bz2 funciona correctamente hasta que me dá este error:
Código:
extra/locale/gen_wctype.c: In function 'main':
extra/locale/gen_wctype.c:759:2: warning: #warning fix the upper bound on the upper/lower tables... save 200 bytes or so
extra/locale/gen_wctype.c:654:9: warning: 'n' may be used uninitialized in this function
extra/locale/gen_wctype.c:654:12: warning: 'sc' may be used uninitialized in this function
extra/locale/gen_wctype.c:655:9: warning: 'i0' may be used uninitialized in this function
extra/locale/gen_wctype.c:655:13: warning: 'i1' may be used uninitialized in this function
  GEN extra/locale/wctables.h
  HOSTCC extra/locale/gen_ldc
  GEN extra/locale/locale_data.c
  GEN extra/locale/uClibc_locale_data.h
  GEN include/bits/uClibc_locale_data.h
  AS lib/crt1.o
libc/sysdeps/linux/mips/crt1.S: Assembler messages:
libc/sysdeps/linux/mips/crt1.S:117: Warning: No .cprestore pseudo-op used in PIC code
  AS lib/Scrt1.o
libc/sysdeps/linux/mips/crt1.S: Assembler messages:
libc/sysdeps/linux/mips/crt1.S:117: Warning: No .cprestore pseudo-op used in PIC code
  AS lib/crti.o
  AS lib/crtn.o
/tmp/ccODiZjm.s: Assembler messages:
/tmp/ccODiZjm.s: Error: .size expression for _init does not evaluate to a constant
/tmp/ccODiZjm.s: Error: .size expression for _fini does not evaluate to a constant
make[1]: *** [lib/crtn.o] Error 1
make[1]: se sale del directorio «/tmp/vdr-ng-em/build/uClibc-0.9.30.3»
make: *** [/tmp/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.uclibc_compiled] Error 2
avatar
papaloukas

Cantidad de envíos : 25
Fecha de inscripción : 23/09/2008
Localización : Bajo el aro

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por papaloukas el Lun 5 Sep 2011 - 18:40

He probado a compilar desde mi home y obtengo el mismo error:
Código:
Warning: adding UNDEFINED entry for af_ZA
  GEN extra/locale/lt_defines.h
  HOSTCC extra/locale/gen_wctype
extra/locale/gen_wctype.c: In function 'main':
extra/locale/gen_wctype.c:759:2: warning: #warning fix the upper bound on the upper/lower tables... save 200 bytes or so
extra/locale/gen_wctype.c:654:9: warning: 'n' may be used uninitialized in this function
extra/locale/gen_wctype.c:654:12: warning: 'sc' may be used uninitialized in this function
extra/locale/gen_wctype.c:655:9: warning: 'i0' may be used uninitialized in this function
extra/locale/gen_wctype.c:655:13: warning: 'i1' may be used uninitialized in this function
  GEN extra/locale/wctables.h
  HOSTCC extra/locale/gen_ldc
  GEN extra/locale/locale_data.c
  GEN extra/locale/uClibc_locale_data.h
  GEN include/bits/uClibc_locale_data.h
  AS lib/crt1.o
libc/sysdeps/linux/mips/crt1.S: Assembler messages:
libc/sysdeps/linux/mips/crt1.S:117: Warning: No .cprestore pseudo-op used in PIC code
  AS lib/Scrt1.o
libc/sysdeps/linux/mips/crt1.S: Assembler messages:
libc/sysdeps/linux/mips/crt1.S:117: Warning: No .cprestore pseudo-op used in PIC code
  AS lib/crti.o
  AS lib/crtn.o
/tmp/ccOVekDI.s: Assembler messages:
/tmp/ccOVekDI.s: Error: .size expression for _init does not evaluate to a constant
/tmp/ccOVekDI.s: Error: .size expression for _fini does not evaluate to a constant
make[1]: *** [lib/crtn.o] Error 1
make[1]: se sale del directorio «/home/papaloukas/src/vdr-ng-em/build/uClibc-0.9.30.3»
make: *** [/home/papaloukas/src/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.uclibc_compiled] Error 2

¿Desde que versión de Linux compilais la rama estable?
avatar
papaloukas

Cantidad de envíos : 25
Fecha de inscripción : 23/09/2008
Localización : Bajo el aro

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Mar 6 Sep 2011 - 10:00

La versión de Linux que uso ahora para compilar es Ubuntu 8.04.4 modo consola a la que le ido metiendo programas, librerías, OpenBox, LXDE, gcc, kernel en tiempo real, etc. compilado manualmente desde el código fuente, así que no sirve como referencia de versión, ya que la base es muy vieja pero los binarios están actualizados independientemente de Ubuntu.

Buscando por google, parece ser que el problema es debido a que el binutils es demasiado moderno para esa versión de uclibc y no están "sincronizados" en el código.

Tú has subido de versión de binutils y eso no se debe hacer.
No entiendo por qué han quitado la versión 2.21 cuando mantienen versiones bastante más viejas, supongo que habrán detectado algún bug gordo.

Tengo que revisarlo y corregir la url de descarga, parches, etc. si fuera necesario para que funcione.

Aquí hay unos parches en los que comentan el error que te da a ti.

Teóricamente guardando este parche en el directorio "patches/uClibc/0.9.30.3" y haciendo un "make" tendría que compilarte bien (dejando el binutils 2.21.1 que tienes ahora).

De todas formas, espero corregirlo esta semana.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por papaloukas el Mar 13 Sep 2011 - 22:23

Hola bittor,

gracias por las instrucciones y comentarios pero si no cambio de versión de binutils (pasar de 2.21 a 2.21.1 no es exactamente "subir"), no hay manera de intentar compilar VDR-NG-EM actualmente.

Aplicando el parche me da este error:
Código:
$make
...
for patch_file in `find  /home/papaloukas/src/vdr-ng-em/patches/uClibc/0.9.30.3 -type f -iname '*.patch' | sort` ; do patch -p1 -E -d  /home/papaloukas/src/vdr-ng-em/build/uClibc-0.9.30.3 < $patch_file ; done
patching file libpthread/linuxthreads/Makefile.in
patching file libpthread/linuxthreads/sysdeps/unix/sysv/linux/mips/sysdep-cancel.h
patching file include/string.h
patching file include/sys/timex.h
Hunk #1 succeeded at 116 with fuzz 1.
patching file libc/unistd/daemon.c
Hunk #1 succeeded at 55 with fuzz 2 (offset 1 line).
patching file libc/sysdeps/linux/common/bits/mathcalls.h
patching file libc/stdio/_scanf.c
Hunk #3 succeeded at 1182 (offset -3 lines).
Hunk #4 succeeded at 1412 (offset -3 lines).
Hunk #5 succeeded at 1453 (offset -3 lines).
Hunk #6 succeeded at 1524 (offset -3 lines).
Hunk #7 succeeded at 1542 (offset -3 lines).
patching file Rules.mak
patching file include/math.h
patching file libc/sysdeps/linux/mips/crti.S
patching file libc/sysdeps/linux/mips/crtn.S
patching file libc/misc/wchar/wchar.c
Hunk #1 succeeded at 1220 (offset -26 lines).
Hunk #2 succeeded at 1419 (offset 15 lines).
patching file libc/misc/wchar/wchar.c
Hunk #1 succeeded at 1389 (offset 21 lines).
Hunk #2 succeeded at 1399 (offset 21 lines).
patching file libc/misc/wchar/wchar.c
Hunk #1 succeeded at 1524 (offset 22 lines).
patching file libpthread/linuxthreads/wrap.c
patching file libpthread/linuxthreads/cancel.c
patching file libpthread/linuxthreads/Makefile.in
Hunk #1 succeeded at 48 with fuzz 1.
patching file libpthread/linuxthreads/manager.c
Hunk #1 succeeded at 1079 (offset 1 line).
patching file libc/stdio/_stdio.c
patching file libc/sysdeps/linux/powerpc/Makefile.arch
Hunk #1 succeeded at 5 with fuzz 2.
patching file libc/sysdeps/linux/powerpc/copysignl.c
patching file libc/inet/resolv.c
Hunk #1 succeeded at 1011 (offset -490 lines).
patching file sysdeps/linux/mips/crtn.S
Hunk #1 FAILED at 23.
Hunk #2 FAILED at 42.
Hunk #3 FAILED at 70.
Hunk #4 FAILED at 90.
Hunk #5 FAILED at 119.
Hunk #6 FAILED at 139.
6 out of 6 hunks FAILED -- saving rejects to file sysdeps/linux/mips/crtn.S.rej
make: *** [/home/papaloukas/src/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.uclibc_patched] Error 1
Seria cuestión de ver otro parche no?

Edito Parece que ya hay otro parche que toca el mismo fichero: 220-sysdep-gnu99-patch.patch
avatar
papaloukas

Cantidad de envíos : 25
Fecha de inscripción : 23/09/2008
Localización : Bajo el aro

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Miér 14 Sep 2011 - 11:20

Tranquilidad, que ando un poco liado.

Ayer compilé con el nuevo binutils 2.21.1 y uClibc 0.9.30.3, pero tengo que comprobar que el firmware generado se instala bien y funciona todo correctamente.

Precisamente el parche que decía en el anterior mensaje no funciona porque el 220-sysdep-gnu99-patch.patch modifica algunas cosas y hay que ajustarlo.

Intentaré probarlo hoy o mañana, así que en breve estará corregido.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por papaloukas el Miér 14 Sep 2011 - 12:29

Ok, no te preocupes, sé que esto es un hobby. Yo lo he dejado compilando sin el parche 220-sysdep-gnu99-patch.patch , a ver que tal. Muchas gracias!
avatar
papaloukas

Cantidad de envíos : 25
Fecha de inscripción : 23/09/2008
Localización : Bajo el aro

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Miér 14 Sep 2011 - 20:33

Ya he probado que funciona bien y lo he subido al SVN, así que si dejas los parches como estaban y ejecutas un
Código:
svn update
make
tendrás la versión compilada sin errores.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por papaloukas el Jue 15 Sep 2011 - 19:08

bittor escribió:Ya he probado que funciona bien y lo he subido al SVN, así que si dejas los parches como estaban y ejecutas un
Código:
svn update
make
tendrás la versión compilada sin errores.
Umm todavia me un error porque no tengo instalado "unzip". Habría que añadirlo en las instrucciones del wiki.
Código:
(cd /home/papaloukas/src/vdr-ng-em/build/m7x0-modules ; unzip -x /home/papaloukas/src/vdr-ng-em/downloads/fw-siemens-m740-2.4.zip)
/bin/sh: unzip: orden no encontrada
make: *** [/home/papaloukas/src/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.m7x0-modules-m740_unpacked] Error 127
Voy a instalar unzip y recompilar.

Actualizo:
Tras empezar desde cero con unzip instalado, me da este error:
Código:
make[1]: se ingresa al directorio «/home/papaloukas/src/vdr-ng-em/build/slin_m740_pro»
rm -f include/asm
( cd include ; ln -sf asm-mips asm)
/bin/sh scripts/Configure -d arch/mips/config.in
#
# Using defaults found in .config
#
scripts/Configure: línea 546: .: .config: no se encontró el fichero
make[1]: *** [oldconfig] Error 1
make[1]: se sale del directorio «/home/papaloukas/src/vdr-ng-em/build/slin_m740_pro»
make: *** [/home/papaloukas/src/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.siemens-linux-kernel_m740_pro_configured] Error 2
¿Como lo puedo solucionar? Veo que este problema ya se ha tratado en el foro. Ahora ya compila con éxito.
avatar
papaloukas

Cantidad de envíos : 25
Fecha de inscripción : 23/09/2008
Localización : Bajo el aro

Ver perfil de usuario

Volver arriba Ir abajo

Compilación de versión trunk 1131

Mensaje por pelloerrota el Lun 31 Oct 2011 - 8:57

Esta noche he compilado la última versión que hay en el repositorio (trunk 1131) y me han salido unos ficheros bastante más grandes que los que salían hasta ahora:
open7x0.org-m740-pro.ofi 8527318bytes
open7x0.org-m740-pro.wsw 8586632bytes

¿Son correctos estos tamaños?

Un saludo,

Pello

pelloerrota

Cantidad de envíos : 10
Fecha de inscripción : 09/04/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Lun 31 Oct 2011 - 9:18

Ahora el tamaño es mucho mayor porque se ha añadido mediatomb (servidor DLNA) y sus dependencias, el servidor NFS en espacio de kernel, se usan optimizaciones del gcc que aumentan el tamaño de los binarios, ... y también se está usando el JFFS2 (/etc) para aprovechar mejor el espacio del firmware, pero hasta los 12 Megas aproximadamente no hay problema.

Si se excede ese tamaño porque tocas alguna configuración del .config te avisará y no terminará la compilación.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por pelloerrota el Lun 31 Oct 2011 - 10:33

Kaixo bittor, gracias por tu rápida respuesta.

En principio, si no me interesa el servidor DLNA, lo que procede es desactivar la opción del mediatomb en la configuración ¿no?

Un saludo y gracias,

Pello

pelloerrota

Cantidad de envíos : 10
Fecha de inscripción : 09/04/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Lun 31 Oct 2011 - 16:54

Por defecto los servidores DLNA y NFS vienen desactivados, así que no tendrás que hacer nada.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por telete el Miér 7 Dic 2011 - 19:01

¿Que versión de gcc hace falta?
Tengo Ubuntu 11.10 y me sale lo siguiente:
Código:
/VDR-NG-EM/VDR-NG-FW/make-incs/egcs.mk:39: *** egcs needs gcc version < 4.0.  Alto.

He visto un post en el que se dice que no es necesaria la 3.4 por lo que no he instalado esta version.

Un saludo
avatar
telete

Cantidad de envíos : 137
Fecha de inscripción : 23/09/2008
Localización : Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por telete el Miér 7 Dic 2011 - 19:05

bittor escribió:Por cierto, ¿no estarás usando el "export CC=/usr/bin/gcc-3.4"?
Es que en la rama trunk ya no hace falta esa versión y esto puede ocasionar que no se compilen las nuevas librerías.

Mejor prueba a ejecutar "$CC --version".

Este es el post al que me refiero.
Yo uso la versión:
Código:
gcc (Ubuntu/Linaro 4.6.1-9ubuntu3) 4.6.1
avatar
telete

Cantidad de envíos : 137
Fecha de inscripción : 23/09/2008
Localización : Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Vie 9 Dic 2011 - 8:58

Está claro que no estás intentando compilar la rama trunk de la que se habla en este mensaje, ya que el error sería
egcs needs gcc version < 5.0
es decir, que a ti te sale que hace falta un gcc < 4.0 pero en trunk el mensaje es que hace falta un gcc < 5.0.

Sigue los pasos que se comentan en este mensaje.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por telete el Lun 19 Dic 2011 - 21:25

Gracias bittor, ha sido un lapsus. Estaba intentando compilar con las instrucciones de la wiki. Gracias, ahora ya está compilando
avatar
telete

Cantidad de envíos : 137
Fecha de inscripción : 23/09/2008
Localización : Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por gonsso el Mar 3 Ene 2012 - 9:29

No se si corresponde a este hilo pero desde que puse una de las ultimimas versiones (creo recordar que aparece como 0.7 pro version svn 1035 o algo asi) la que incluye servidor dlna y nfs. Pues bien el servidor dlna funciona de maravilla para lo que yo queria pero me encuentro con el problema de que a traves de web no puedo grabar, al pinchar sobre el programa no se abre la explicacion y aparece el boto de grabar, no se si es un problema general o es algo de mi navegador (utilizo firefox y no se si es que ahora necesita algun plugin) Antes tenia una version 0.6 svn 867 y funcionaba bien. Gracias y feliz año a toda la comunidad.

gonsso

Cantidad de envíos : 49
Fecha de inscripción : 19/02/2010
Edad : 45

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Mar 3 Ene 2012 - 16:18

Prueba con otro navegador.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por gonsso el Miér 4 Ene 2012 - 8:51

bittor escribió:Prueba con otro navegador.

Perdona se me olvido decir que tambien habia probado con IE 8 y tampoco funciona. Seguiere haciendo pruebas...

gonsso

Cantidad de envíos : 49
Fecha de inscripción : 19/02/2010
Edad : 45

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Miér 4 Ene 2012 - 8:53

Es que se había comentado que con algunos navegadores (en principio era en Touchs) no funcionaba, pero atinar ya lo tenía resuelto y lo iba a subir cuando pudiera.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por gonsso el Miér 4 Ene 2012 - 9:03

bittor escribió:Es que se había comentado que con algunos navegadores (en principio era en Touchs) no funcionaba, pero atinar ya lo tenía resuelto y lo iba a subir cuando pudiera.

Lo habia leido por el foro y por eso lo comentaba, para que alguien mas probase

gonsso

Cantidad de envíos : 49
Fecha de inscripción : 19/02/2010
Edad : 45

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por Videre el Miér 4 Ene 2012 - 15:03

Pues a mi también me ha empezado a pasar con el nuevo firmware que me he puesto. El mismo con el que tengo el problema con el plugin rssreader. Estas son las revisiones:
Código:

** Versión del firmware **
VDR-NG-EM pre 0.7 Pro BETA
SVN ToolChain 1139M
SVN VDR 1138
SVN VDR-plugins 1138
SVN webif 1068M

** Versión de VDR **
vdr (1.4.7/1.4.5/Preview 2011-12-11 22:33 (VDR-NG-EM version: pre 0.7 BETA)) - The Video Disk Recorder

Antes me funcionaba perfectamente con el Firefox y con el Opera en el movil. Ahora no me va en ninguno de los dos. Viendo el código fuente no encuentro ningún enlace ni llamada a javascript donde debería haberlo:
Código:
<span class="t">14:59</span></span> <span class="end"><span class="l">Final </span><span class="t">16:05</span></span> <span class="duration">(<span class="l">Duración</span>: <span class="t">66</span> minutos aprox.)</span></span>

<span class="title titleLink">Telediario 1º Edición 2011</span>
Puesto que atinar va a cambiar la versión, tampoco me preocuparía mucho.

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por gonsso el Miér 4 Ene 2012 - 23:07

La version que yo tengo es:
Código:

VDR-NG-EM pre 0.7 Pro BETA
SVN ToolChain 1138M
SVN VDR 1138
SVN VDR-plugins 1138M
SVN webif 1068M




Este es una parte del codigo fuente de la pagina de inicio Parrilla TV
Código:

<div class="eventContent ">
<span class="more">+</span>
<ul class="controls"><!--
--><li class="control"><a class="timerCreate button-i ui-state-default" href="/timers.kl1?a=16&amp;channelNum=1&amp;eventId=53337" title="Programar grabación"><span class="ui-icon ui-icon-rec">Programar grabación</span></a></li><!--
--><li class="control"><a class="searchCreate button-i ui-state-default" href="/searches.kl1?a=17&amp;channelNum=1&amp;eventId=53337" title="Crear búsqueda EPG"><span class="ui-icon ui-icon-search">Crear búsqueda EPG</span></a></li><!--
--></ul><!--
--><span class="fromTo"><span class="start"><span class="l">Inicio&nbsp;</span><span class="t">23:53</span></span> <span class="end"><span class="l">Final&nbsp;</span><span class="t">01:46</span></span> <span class="duration">(<span class="l">Duración</span>: <span class="t">112</span> minutos aprox.)</span></span>

<span class="title titleLink">Virgen A Los 40</span>
<div class="desc">
<p>Año: 2005; Director: Judd Apatow; Reparto: Steve Carell, Catherine Keener, Paul Rudol, Romany Malco, Seth Rogen, Elizabeth Banks, Les; Andy es un hombre adorable que pasa de "no haberlo hecho nunca" a "eso ya me lo sé yo" por seguir los desastrosos consejos que le dan sus amigos y que casi deja pasar la oportunidad de encontrar lo que lleva tantos años buscando.</p>
</div>
</div>
</li><li id="e-53338" class="event" style="left:65.88%;width:34.12%">


Se ven unas lineas comentadas con
Código:
<!--

no se si puede ser eso

gonsso

Cantidad de envíos : 49
Fecha de inscripción : 19/02/2010
Edad : 45

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por telete el Jue 16 Feb 2012 - 17:56

A la mitad del hilo a alguien le paso lo que a mi, pero no he conseguido saber como lo solucionó.
Os pongo el error que me dá

Código:

make -C /home/anakin/vdr-ng-em/hostutils.build/cloog-ppl-0.15.11
make[1]: se ingresa al directorio «/home/anakin/vdr-ng-em/hostutils.build/cloog-ppl-0.15.11»
Making all in .
make[2]: se ingresa al directorio «/home/anakin/vdr-ng-em/hostutils.build/cloog-ppl-0.15.11»
/bin/sh ./libtool --tag=CC  --mode=link gcc -Wall -fomit-frame-pointer -g -O2  -L/home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib -L/home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib  -o cloog cloog.o libcloog.la -lm -lgmp -lppl_c -lppl -lgmpxx -lstdc++
libtool: link: gcc -Wall -fomit-frame-pointer -g -O2 -o cloog cloog.o  -L/home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib ./.libs/libcloog.a -lm /home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib/libppl_c.a /home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib/libppl.a /home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib/libgmpxx.a /home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib/libgmp.a -lstdc++
/usr/bin/ld: /home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/lib/libppl.a(MIP_Problem.o): undefined reference to symbol 'sqrt@@GLIBC_2.0'
/usr/bin/ld: note: 'sqrt@@GLIBC_2.0' is defined in DSO /usr/lib/gcc/i686-linux-gnu/4.6.1/../../../i386-linux-gnu/libm.so so try adding it to the linker command line
/usr/lib/gcc/i686-linux-gnu/4.6.1/../../../i386-linux-gnu/libm.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [cloog] Error 1
make[2]: se sale del directorio «/home/anakin/vdr-ng-em/hostutils.build/cloog-ppl-0.15.11»
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio «/home/anakin/vdr-ng-em/hostutils.build/cloog-ppl-0.15.11»
make: *** [/home/anakin/vdr-ng-em/m7x0_xtc_uclibc_Linux-i686/stagefiles/.cloog_host_compiled] Error 2

Creo que bittor lo había solucionado, pero yo no lo consigo.

La revisión es la 1149
avatar
telete

Cantidad de envíos : 137
Fecha de inscripción : 23/09/2008
Localización : Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por bittor el Vie 17 Feb 2012 - 8:49

Sí, ese error también me dió al usar Arch y lo solucioné como indica el mensaje, añadiendo la librería math al enlazador, es decir, añadiendo "-lm" y en el error que a ti te da sale el "-lm", por lo que algo raro pasa.
¿has hecho una compilación de cero o has usado "make clean distclean" antes de ejecutar el "make"?
¿qué distribución de Linux usas?
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: es usable el trunk?

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 2 de 6. Precedente  1, 2, 3, 4, 5, 6  Siguiente

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.