Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Problemas compilando versión trunk

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas compilando versión trunk

Mensaje por atinar el Jue 8 Dic 2011 - 14:12

Llevo un tiempo tratando de compilar la versión trunk y me estoy encontrando unos cuantos problemas:

Inicialmente me fallaba al compilar el ppl. Eso se solucionaba con un parche que hay por ahí, y que ya está en el repositorio, pero desconozco por qué no le daba problemas a nadie más. Sospecho que alguno de los otros problemas puede depender de la distribución de linux que cada cual utilice, pero ese problema no tiene la pinta de tener nada que ver.

Solucionado eso, en determinado punto, se sigue empeñando en confundir el directorio ../../.config con el directorio /.config. Aunque no se parecen mucho, la verdad. Se queja de eso y termina con un contundente "Stop". No entiendo por qué ocurre y me obliga a eliminar ese directorio (que creo que es estándar en escritorios KDE) cada vez.

A partir de ahí, sigue bien hasta el momento de instalar ntpclient. Trata de copiarlo a .../target-root/usr/sbin. Sólo que sbin no existe. Quizá se tiene que crear ese directorio en algún punto anterior que se está omitiendo. Pero en todo caso se debería comprobar en el ntpclient.mk.

Si después de crear ese directorio a mano, trato de seguir con el make, entonces falla al tratar de aplicar los parches a tcp_wrappers_7.6, porque los archivos en cuestión tienen sólo permiso de lectura.

Y ahí lo he dejado...

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas compilando versión trunk

Mensaje por bittor el Vie 9 Dic 2011 - 9:28

atinar escribió:Inicialmente me fallaba al compilar el ppl. Eso se solucionaba con un parche que hay por ahí, y que ya está en el repositorio, pero desconozco por qué no le daba problemas a nadie más. Sospecho que alguno de los otros problemas puede depender de la distribución de linux que cada cual utilice, pero ese problema no tiene la pinta de tener nada que ver.
Supongo que depende de las versiones de programas que se tengan instalados y de si la distribución hace cambios propios en el entorno, rutas, etc.

atinar escribió:Solucionado eso, en determinado punto, se sigue empeñando en confundir el directorio ../../.config con el directorio /.config. Aunque no se parecen mucho, la verdad. Se queja de eso y termina con un contundente "Stop". No entiendo por qué ocurre y me obliga a eliminar ese directorio (que creo que es estándar en escritorios KDE) cada vez.
Quizás tiene algo que ver con lo que se comentaba aquí:
http://vdr-m7x0.foroactivo.com.es/problemas-encontrados-f5/solucionado-error-al-compilar-el-nuevo-firmware-t1036.htm#14505

atinar escribió:A partir de ahí, sigue bien hasta el momento de instalar ntpclient. Trata de copiarlo a .../target-root/usr/sbin. Sólo que sbin no existe. Quizá se tiene que crear ese directorio en algún punto anterior que se está omitiendo. Pero en todo caso se debería comprobar en el ntpclient.mk.
Tienes razón, esto es un fallo del toolchain porque no crea una estructura de directorios base para que los programas puedan copiar los archivos.
Tal y como dices, cada programa tendría que comprobar si existe el directorio antes de copiar y si no existe crearlo.
Cuando tenga un rato lo arreglo, aunque para no revisarme los 88 makefiles de programas que tenemos, crearé la estructura estándar de directorios la primera vez y así se corregirá el problema.

atinar escribió:Si después de crear ese directorio a mano, trato de seguir con el make, entonces falla al tratar de aplicar los parches a tcp_wrappers_7.6, porque los archivos en cuestión tienen sólo permiso de lectura.
Pues si que es raro ya que a nadie más le ha pasado esto.
En cuanto pueda me bajo el archivo y lo descomprimo a ver si los archivos están de sólo lectura.
avatar
bittor
Desarrollador

Cantidad de envíos : 3632
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.