Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



configurar mediatomb

Ver el tema anterior Ver el tema siguiente Ir abajo

configurar mediatomb

Mensaje por lornys1 el Dom 3 Feb 2013 - 19:27

Buenas tardes,

Después de varios años he vuelto a coger el m740, para darle caña.

El caso es que estoy intentando hacer funcionar el mediatomb en la versión 0.7.

Hace cosa de medio año compilé e instalé la última versión pero lo deje de lado por falta de tiempo. Ahora quiero usarlo para grabar y poder ver las cosas a través del DLNA de la tv pero no consigo que arranque el mediatomb. el otro dia que es cuando lo volví a coger llegé a entrar en http://192.168.0.199:49152/ que es la ip del M740 y el puerto del servidor DLNA, pero después le hice un reset a valores de fábrica desde el menú y ahora no soy capaz de entrar a esa página lo que me dice que no está activo. Lo he activado en la configuración y reiniciado pero nada. Mi idea era conectar un android pc con XBMC a la TV y dejar el M740 para grabar por su probada estabilidad, pero hasta que no consiga activar el DLNA no puedo seguir para ver como conectarlo al XBMC.


Muchas gracias.

lornys1

Cantidad de envíos : 12
Fecha de inscripción : 03/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por bittor el Dom 3 Feb 2013 - 21:54

Mira el archivo /var/log/messages para ver si hay algún problema.
Por cierto, de momento para que funcione el mediatomb es necesario que haya conectado un disco duro al usb.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por lornys1 el Lun 4 Feb 2013 - 18:10

En el archivo que comentas no veo nada que haga referencia a mediatomb. por otro lado sí tengo un disco por usb con una grabación en él. Como errores veo lo siguiente:
Feb 3 20:16:03 (none) user.err vdr: [107] ERROR (svdrp.c,429): Broken pipe
Feb 4 18:01:22 (none) local0.warn webif: [wrn][133:broker.c:135:broker_create] Kilt support disabled, use --enable_kilt to enable it
Feb 4 18:01:22 (none) local0.warn webif: [wrn][133:broker.c:142:broker_create] CGI support disabled, use --enable_cgi to enable it

Si ejecuto mediatomb desde telnet:

~ # mediatomb .

MediaTomb UPnP Server version 0.12.1 - http://mediatomb.cc/

===============================================================================
Copyright 2005-2010 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2

2013-02-04 18:05:51 INFO: Loading configuration from: /root/.mediatomb/config.xml
2013-02-04 18:05:52 INFO: Checking configuration...
2013-02-04 18:05:52 ERROR: /home/vdr/m7x0_xtc_uclibc_Linux-i686/target_root/usr/share/mediatomb/web : 20 x No such file or directory

No entiendo de donde sale esa ruta, de todas formas en /home no hay nada de nada, no se si será normal.

Edito.

Según veo, esa ruta sale del archivo de configuración que está en/root/.mediatomb/, no lo toco porque no se si esa ruta es así o tiene que apuntar a otro archivo. Supongo que borrando el config.xml que hay en /root/.mediatomb el programa cogerá el que hay bajo /etc/mediatomb, pero he copiado el config.xml de /etc a /root guardando el que había y nada:
2013-02-04 18:22:07 ERROR: Error parsing config file: /root/.mediatomb/config.xml line 48:
Está es la línea:
<import hidden-files="no">

lornys1

Cantidad de envíos : 12
Fecha de inscripción : 03/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por bittor el Lun 4 Feb 2013 - 20:53

Los errores del webif son normales.

Para ejecutar el mediatomb por telnet tienes que usar "start-mediatomb" y no mediatomb porque te ha creado esos archivos con rutas erróneas, pero no pasa nada, ejecuta el script que te digo a ver que te sale.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por lornys1 el Lun 4 Feb 2013 - 21:04

Sí, efectivamente estaba levantando mal el servidor, ya que como yo lo hacía creo que lo ejecutaba el usuario root.

De todas formas el problema venía por otro lado. El otro día, antes de cargar los valores de fábrica estuve toqueteando el archivo de configuración (ni probé esas modificaciones) y algo debí dejar mal. lo que he echo ha sido iniciar una compilación del firm en linux, he cogido el "config.xml" de la carpeta que se crea y funcionando. Mea culpa. Pensaba que al cargar valores de fábrica recargaría los archivos de configuración.
Ahora a pelearme con XMBC a ver si consigo que vea los archivos .rec del Giga. Y porqué no, que mi samsung vea el mediatomb.

Muchas gracias por todo bittor.

lornys1

Cantidad de envíos : 12
Fecha de inscripción : 03/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por bittor el Lun 4 Feb 2013 - 21:36

Realmente el factory reset tendría que restaurar los archivos de configuración y si no lo hace con este, habrá que corregirlo para la próxima versión.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por lornys1 el Lun 4 Feb 2013 - 22:11

Mañana modifico el archivo de configuración, y hago un factory reset desde el menú y otro desde los 4 enchufazos (no se si es exactamente igual) y confirmo si se restaura o no (yo pondría la mano en el fuego que hice las modificaciones antes del factory reset, pero con esta cabeza...).

Saludos.

lornys1

Cantidad de envíos : 12
Fecha de inscripción : 03/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por bittor el Mar 5 Feb 2013 - 9:08

No hace falta que hagas la prueba, ya te adelanto que ese archivo no se restaura y habrá que añadirlo.

Gracias por notificarlo.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: configurar mediatomb

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.