Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Problemas en el interfaz web

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas en el interfaz web

Mensaje por r5004 el Vie 25 Dic 2015 - 9:20

Tengo 2 problemas en el webif, con el último firmware (1412).
El primero debe ser algo relacionado con la codificación de caracteres. Al crear una programación, si el nombre contiene algún carácter "especial" como à,é,ï,ç, se modifica automáticamente con caracteres "raros". Desde este momento, esta programación ya no se puede modificar ni borrar desde el webif (sí que se puede con el mando a distancia). Si modifico la programación con el mando y corrijo el nombre, en el webif tampoco se puede modificar ni borrar.
Pongo una imágenes del proceso + el log de la programación:












Dec 25 08:09:19 (none) user.info vdr: [107] connect from 127.0.0.1, port 3082 - accepted
Dec 25 08:09:21 (none) user.info vdr: [107] timer 1 (1 2145-2245 'Zona zàping') set to event Vie 25.12.2015 21:57-22:24 'Zona zàping'
Dec 25 08:09:24 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:09:48 (none) user.info vdr: [107] connect from 127.0.0.1, port 3083 - accepted
Dec 25 08:09:50 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:13:58 (none) user.info vdr: [107] connect from 127.0.0.1, port 3084 - accepted
Dec 25 08:14:00 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:14:01 (none) user.info vdr: [140] EPGSearch: timer conflict check started
Dec 25 08:14:01 (none) user.info vdr: [140] timer 1 (1 2145-2245 'Zona zàping') set to event Vie 25.12.2015 21:57-22:24 'Zona zàping'
Dec 25 08:14:01 (none) user.info vdr: [140] EPGSearch: timer conflict check finished
Dec 25 08:15:04 (none) ftp.info vsftpd[150]: [nobody] OK DOWNLOAD: Client "192.168.1.5", "/var/media/vdr1/Fringe_-_Llibertat/2015-12-25.01.54.50.99.rec/003.vdr", 765329408 bytes, 1888.69Kbyte/sec
Dec 25 08:15:07 (none) local0.warn webif: [wrn][137:toolbox/str.c:418:u_string_aiconv] iconv_cd == (iconv_t) (-1) [errno: 22, Invalid argument]
Dec 25 08:15:08 (none) user.info vdr: [107] connect from 127.0.0.1, port 3085 - accepted
Dec 25 08:15:08 (none) user.info vdr: [107] timer 5 (12 2100-0315 'EQUIPO DE INVESTIGACIÓN') added
Dec 25 08:15:10 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:15:52 (none) local0.warn webif: [wrn][135:toolbox/str.c:418:u_string_aiconv] iconv_cd == (iconv_t) (-1) [errno: 22, Invalid argument]
Dec 25 08:15:53 (none) user.info vdr: [107] connect from 127.0.0.1, port 3086 - accepted
Dec 25 08:15:54 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:15:56 (none) user.info vdr: [107] timer 5 (12 2100-0315 'EQUIPO DE INVESTIGACIÓN') set to event Vie 25.12.2015 21:30-02:45 'EQUIPO DE INVESTIGACIÓN'
Dec 25 08:16:56 (none) local0.warn webif: [wrn][137:toolbox/str.c:418:u_string_aiconv] iconv_cd == (iconv_t) (-1) [errno: 22, Invalid argument]
Dec 25 08:16:57 (none) user.info vdr: [107] connect from 127.0.0.1, port 3087 - accepted
Dec 25 08:16:58 (none) user.info vdr: [107] closing SVDRP connection
Dec 25 08:17:15 (none) local0.warn webif: [wrn][135:toolbox/str.c:418:u_string_aiconv] iconv_cd == (iconv_t) (-1) [errno: 22, Invalid argument]



El segundo problema. En la guía de programación del webif, sólo se ven los iconos de "programar grabación" "crear búsqueda epg" y "buscar en internet" en la primera columna (en la otras dos, en su lugar aparece un espacio en blanco). Esto ocurre con el Chrome (en ordenador con Windows) y en Opera y Chrome (en Android). En Firefox (en ordenador con Windows y en Android) sí que aparecen todos los iconos. Más imágenes:



¡¡¡¡Feliz Navidad!!!!

r5004

Cantidad de envíos : 31
Fecha de inscripción : 28/09/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por bittor el Sáb 26 Dic 2015 - 18:17

Feliz navidad !!

El problema de la codificación lo descubrí casualmente la semana pasada con el mediatomb ya que no arranca por ese problema (es necesario forzarle la codificación UTF-8 pero el firm usa ISO-8859-15) y supongo que se debe a algo que ha cambiado en la nueva librería uClibc relacionado con el iconv, pero todavía no lo he detectado para corregirlo.

Del segundo problema tendría que investigarlo a ver, seguro que es algún CSS que no le gusta a algún navegador.

Intentaré corregirlos en cuanto pueda.
avatar
bittor
Desarrollador

Cantidad de envíos : 3632
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por bittor el Mar 29 Dic 2015 - 13:38

El problema de la codificación ya está corregido en la última versión del SVN y era debido a que no se incluía ISO-8859-15 en el nuevo uClibc.
Habría que testearlo por si hubiera algún problema, pero tendría que funcionar como antes.

He mirado lo del webif y la estructura HTML es correcta, así que debe ser algo que no le gusta al Chrome y habrá que investigarlo en profundidad.
avatar
bittor
Desarrollador

Cantidad de envíos : 3632
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por r5004 el Dom 3 Ene 2016 - 12:33

bittor escribió:El problema de la codificación ya está corregido en la última versión del SVN y era debido a que no se incluía ISO-8859-15 en el nuevo uClibc.
Habría que testearlo por si hubiera algún problema, pero tendría que funcionar como antes.
Parece que ya está solucionado (con el trunk 1418).
bittor escribió:He mirado lo del webif y la estructura HTML es correcta, así que debe ser algo que no le gusta al Chrome y habrá que investigarlo en profundidad.
Debe de ser algo del Blink (tanto Chrome como Opera están basados en él).

r5004

Cantidad de envíos : 31
Fecha de inscripción : 28/09/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por bittor el Miér 1 Jun 2016 - 20:22

Quería comentar que ya han corregido ese bug en la última versión de Chrome (probado con la 51.0.2704.63) y se ven bien los botones en todas las columnas.

De todas formas he hablado con atinar que es el desarrollador del webif y me ha comentado que hay una opción de configuración del webif llamada "No utilizar columnas CSS para la disposición del contenido" precisamente para evitar problemas con las columnas, así que si vuelve a pasar habría que usar esa opción u otro navegador que funcione bien.
avatar
bittor
Desarrollador

Cantidad de envíos : 3632
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por r5004 el Vie 3 Jun 2016 - 15:42

¡¡Gracias!!
Probado con el Chrome 51.0.2704.79 (en Windows) y parece solucionado. En el móvil, aún no aparecen los botones así que habrá que esperar a la actualización... o seguir usando el Firefox. Very Happy

r5004

Cantidad de envíos : 31
Fecha de inscripción : 28/09/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por r5004 el Vie 10 Jun 2016 - 8:49

r5004 escribió:¡¡Gracias!!
Probado con el Chrome 51.0.2704.79 (en Windows) y parece solucionado. En el móvil, aún no aparecen los botones así que habrá que esperar a la actualización... o seguir usando el Firefox. Very Happy
Con la reciente actualización de Chrome en Android, versión 51.0.2704.81, vuelven también los botones. Smile

r5004

Cantidad de envíos : 31
Fecha de inscripción : 28/09/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Problemas en el interfaz web

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.