Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Error en el menú principal

Ver el tema anterior Ver el tema siguiente Ir abajo

Error en el menú principal

Mensaje por toni_kny el Dom 27 Mar 2016 - 17:43

Buenas,

he instalado la versión del svn 26/03/2016 (en ubuntu 15.10) y aunque la he probado poco, he encontrado algun fallo. No se si sería buena idea empezar otro hilo para ir depurando la 0.8, como tu quieras bittor, pero he visto que sigues haciendo cosillas en el svn, así que supongo que te ira bien si alguno lo vamos probando y reportando.

El fallo en cuestión es que en el menu principal no se puede entrar en las opciones de "plugins" y "configuración". Ni con el mando, ni por svdrp. En el resto de opciones si que deja entrar.

Saludos.

toni_kny

Cantidad de envíos : 21
Fecha de inscripción : 26/03/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por bittor el Mar 29 Mar 2016 - 21:04

Se agradece la información de errores detectados en la versión del SVN, porque yo sólo corrijo lo que detecto y aunque esto del menú ya lo comentó un usuario a mi no me pasa.

En principio se debía a que se restaura un backup anterior y en la nueva versión no están esos plugins o algo similar que se hace la pinza, ¿has restaurado un backup?.

Como es la versión de desarrollo puedes abrir un nuevo mensaje con cada error para no mezclarlos y ver la resolución de cada uno.

En principio estaba solucionado porque después de restaurar el backup borro el archivo /etc/vdr/plugins/MainMenu.conf y entonces se regenera con los plugins que se tengan, prueba a borrarlo por FTP/telnet y entra al menú o a editarlo según los plugins que tengas y si tienes dudas pregunta y lo pones aquí.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por toni_kny el Dom 3 Abr 2016 - 17:49

Como dices, había restaurado un backup. He borrado el MainMenu.conf, pero me vuelve a generar el archivo con el mismo contenido y sigo sin poder entrar a los submenus de plugins y configuracion.

Código:

~ # cat /etc/vdr/plugins/MainMenu.conf
0::Schedule
0::Recordings
0::Timers
0::epgsearchonly
0::conflictcheckonly
0:1:Plugins
0:2:Configuraci�n
2::Setup
2::setup
2:3:Canales
3::channelscan
3::Channels
0::Commands
0::aide
~ #

toni_kny

Cantidad de envíos : 21
Fecha de inscripción : 26/03/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por bittor el Lun 4 Abr 2016 - 9:19

Que no puedas entrar al submenú de Plugins es normal porque no tienes ningún plugin adicional, realmente no tendría que generar esa entrada si no hay ningún plugin adicional, pero está así desde los inicios, miraré de corregirlo.

Lo de no poder entrar al submenú Configuración es un poco raro y no sé por qué no funciona, en cuanto pueda probaré ese MainMenu.conf a ver si puedo reproducir el error.

De momento, para que puedas acceder a la configuración, canales, etc. podrías dejarte el archivo así:
Código:
0::Schedule
0::Recordings
0::Timers
0::epgsearchonly
0::conflictcheckonly
0::Setup
0::setup
0::channelscan
0::Channels
0::Commands

No lo he probado pero debería funcionar bien y se mostrarán todas las entradas sin submenús (el Setup con mayúscula es la configuración del VDR y el setup con minúscula es la del firmware), aunque también puedes agruparlas como quieras.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por toni_kny el Jue 7 Abr 2016 - 9:31

Efectivamente, con ese MainMenu.conf funciona.

Veo que vas metiendo actualizaciones al svn, cuando creas que es buen momento vuelvo a compilar. De momento, con la última todo correcto.

Saludos.

toni_kny

Cantidad de envíos : 21
Fecha de inscripción : 26/03/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por bittor el Dom 10 Abr 2016 - 15:46

Ahora es buen momento para testear la versión del SVN porque ya he subido todos los cambios que tenía pendientes, los más destacados son usar la librería uClibc-ng y la versión de desarrollo del gcc 6 que está a punto de su versión final, el Busybox usa Link Time Optimization y unas cuantas mejoras en el VDR y algunos plugins.

La mejora de rendimiento con el gcc 6 + LTO que usamos en la mayoría de programas del firm es notable, en este blog buscando en el texto "time needed to convert" (para ir a las gráficas que nos interesan) puede verse la gran diferencia.

Que le cuesta compilar más tiempo o consuma más RAM cuando compila nos es indiferente, porque lo que queremos son unos binarios que vuelen Smile

Respecto al menú, he probado el que has puesto y me funciona sin problemas.

Puedes probar la última versión del SVN que ya no generará el submenú "Plugins" si no hay plugins adicionales y justo después de instalarla mira a ver si te funciona bien el menú, después restauras el backup y vuelves a comprobar.

Si te sigue sin funcionar meteré en el código información de depuración para ver cual es el problema.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por toni_kny el Lun 11 Abr 2016 - 10:36

bittor escribió:
Respecto al menú, he probado el que has puesto y me funciona sin problemas.

Puedes probar la última versión del SVN que ya no generará el submenú "Plugins" si no hay plugins adicionales y justo después de instalarla mira a ver si te funciona bien el menú, después restauras el backup y vuelves a comprobar.

Si te sigue sin funcionar meteré en el código información de depuración para ver cual es el problema.

Después de instalar la versión 1471, el menu funciona bien de serie, pero al restaurar la copia de seguridad pasa lo mismo que antes, pero ahora sin el menu de plugins. Es decir, no puedo entrar a la configuración desde el menú principal.

He probado editar el MainMenu.conf a mano para descartar que fuera problema de codificación, pero tampoco ha funcionado.

Este es el contenido después de restaurar:
Código:
~ # cat /etc/vdr/plugins/MainMenu.conf
0::Schedule
0::Recordings
0::Timers
0::epgsearchonly
0::conflictcheckonly
0:1:Configuraci�n
1::Setup
1::setup
1:2:Canales
2::channelscan
2::Channels
0::Commands
0::aide

toni_kny

Cantidad de envíos : 21
Fecha de inscripción : 26/03/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por bittor el Lun 11 Abr 2016 - 19:59

Perfecto, tenemos acotado el problema a algo que pasa al restaurar una copia de seguridad.

¿podrías subir la copia a algún sitio para ver si puedo reproducir el problema?
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por toni_kny el Lun 11 Abr 2016 - 21:24

Aquí te dejo la copia de seguridad:
https://www.dropbox.com/s/l9b7j3tr5zye3x5/vdr_conf.vcf?dl=0

He probado restaurar los enlaces del menú, desde el mando y me vuelve a crear los mismos enlaces que al restaurar, los que no van bien. Por si ayuda.

toni_kny

Cantidad de envíos : 21
Fecha de inscripción : 26/03/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por bittor el Mar 12 Abr 2016 - 9:05

Thx, revisaré a ver si puedo reproducir el error y corregirlo.

A simple vista veo que la copia debe ser de la 0.6 o anterior porque por ejemplo en el /etc/rc.conf está la IP que hace muchísimo que ya no está y en el /etc/vdr/keymacros.conf están estos dos comandos
Código:
FastFwd  Commands 5 2
FastRew  Commands 5 1
que tampoco funcionan desde hace años.

Pero bueno, lo importante es que hay un bug porque se tendría que poder restaurar cualquier copia.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Error en el menú principal

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.