Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Logos skin enigma

Página 1 de 2. 1, 2  Siguiente

Ver el tema anterior Ver el tema siguiente Ir abajo

Logos skin enigma

Mensaje por yeahhh el Miér 19 Nov 2008 - 15:18

Buenas, a alguien le sale el logo de Intereconomía?
No tengo co....s de que salga.
En el channels.conf lo tengo como Intereconomía (con acento en la i) pero ni con esas me lo pilla.
He probado de mil maneras con el nombre, pero no hay manera, se os ocurre algo?
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Posix el Miér 19 Nov 2008 - 18:32

Cuando cambias de canal y no encuentra el icono, en el log /var/log/messages aparece una línea indicándolo:

EnigmaNG: cPluginSkinEnigma::LoadChannelLogo: LOGO "PROMO.xpm" NOT FOUND in /etc/vdr/plugins/skinenigmang/[hq]logos

Si el fichero existe, puede que esté mal el xpm. Te puedo enviar el mio.
avatar
Posix
Desarrollador

Cantidad de envíos : 691
Fecha de inscripción : 05/11/2008
Edad : 50
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por yeahhh el Miér 19 Nov 2008 - 19:59

Pregunta "tonta" el directorio se llama hqlogos o [hq]logos?
Porque yo lo tengo como hqlogos y me coge todos.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Krako el Miér 19 Nov 2008 - 20:20

Los dos sirven. Si no se encuentra un logo apropiado en el directorio 'Enigma/hqlogos' intentará encontrarlo en el directorio 'Enigma/logos' o tambien se puede hacer un enlace simbólico.

Salu2, 8)

_________________

M740: VDR-NG-EM 0.7 Pro (Última revisión) + Plugins
LAN 100Mbits + HDD USB WDElements 640Gb (3*ext2)

Wiki Foro Download
avatar
Krako
Moderador

Cantidad de envíos : 415
Fecha de inscripción : 25/06/2008
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por yeahhh el Miér 19 Nov 2008 - 21:24

Pues no funciona :x creo que es por el p..o acento de la cadena.
Cuando luego entro otra vez por ftp, igual me sale así Intereconom6a, y cosas "raras".
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Videre el Miér 19 Nov 2008 - 22:41

Entonces el archivo tendrá que tener el acento y tendrás que renombrarlo si no es así. El problema es que el firmware usa un codificación de caracteres (ISO 8859-1 o Latín 1) y Windows o nuestra distribución de Linux otra.

Con la lista canales de Málaga pasa igual, el archivo tiene el acento con la codificación UTF-8 que es la que usa el svn y la mayoría de distribuciones de Linux modernas. Yo conseguí renombrarlo correctamente dentro del firmware por telnet, pero no he podido subir el cambio al svn porque este no acepta otra codificación que no sea UTF-8.

Prueba a ver si renombrando el archivo desde telnet de esta manera te funciona:
mv Intereconomia.xmp Intereconom$'\xED'a.xpm

Eso creará el fichero Intereconomía.xpm con la codifiación que espera el firmware.

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por yeahhh el Miér 19 Nov 2008 - 23:01

Ok, ya lo he cambiado, cuando pueda cambiar de canal (el internado manda y la jefa también 8) veré a ver si funciona.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Videre el Jue 20 Nov 2008 - 23:47

¿Te funcionó?

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por yeahhh el Vie 21 Nov 2008 - 7:50

Que va! :evil:
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por joseagt el Vie 21 Nov 2008 - 10:29

Hola, puede que esté mal el xpm: a mi me pasó con el logo de Disney Channel, no se veía en el skin enigmaNG, pero en el ordenador sí que lo podía ver correctamente. La solución fue cambiarlo por otro fichero.
Prueba a renombrar otro logo de otra cadena que veas correctamente a Intereconomía.xpm

Saludos
JA
avatar
joseagt
Betatester

Cantidad de envíos : 362
Fecha de inscripción : 26/06/2008
Localización : Valencia

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por yeahhh el Sáb 22 Nov 2008 - 8:56

Al final me lo ha cogido como IntereconomÝa.xpm...
Porque no hay icono de "roto" en este foro... Very Happy
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Mar 9 Dic 2008 - 14:52

yeahhh escribió:Al final me lo ha cogido como IntereconomÝa.xpm...
Porque no hay icono de "roto" en este foro... Very Happy

¿Cómo lo has hecho?
A mí no me lo coge y eso que la i minúscula con acento la pongo con Alt+237.

He probado poner el logo con la i sin acento y luego ir a canales y modificar el nombre poniendo la i sin acento. Me ha funcionado el logo pero a los 3 o 4 minutos deja de funcionar porque "algo" lo vuelve a poner la i con acento. ¿Será que hace una actualización de canal cada 4-5 minutos y hace como un reset?

En fín, que tengo que buscar la forma de hacer una "í" que entienda el vdr-rootfs.

Un saludo.
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Videre el Mar 9 Dic 2008 - 20:42

EnStandby escribió:
He probado poner el logo con la i sin acento y luego ir a canales y modificar el nombre poniendo la i sin acento. Me ha funcionado el logo pero a los 3 o 4 minutos deja de funcionar porque "algo" lo vuelve a poner la i con acento. ¿Será que hace una actualización de canal cada 4-5 minutos y hace como un reset?
Esto es porque el VDR actualiza automáticamente los nombres de las cadenas si han cambiado. Hay una configuración por ahí, no recuerdo donde que te cambia este comportamiento.

EnStandby escribió:
En fín, que tengo que buscar la forma de hacer una "í" que entienda el vdr-rootfs.

Una manera de hacerlo, y yo creo que la mejor por otros temas, es configurar el terminal con que entramos al Gigaset por telnet para que use la codificación de caracteres correcta: en nuestro caso ISO 8859-1 también llamado Latín 1 (o 8859-15, Latín 9, que incluye el €).

Por ejemplo, yo desde Linux uso GNOME Terminal: le cambio la codificación en menú Terminal > Establecer codificación de caracteres > ISO 8859-15. Si usas Windows, seguro que el putty entre los miles de opciones que tiene, tiene una para este tema.

Luego cuando hagas un "mv Intereconom*a.xpm Intererconomía.xpm" te debería poner el acento como Dios manda (o como ISO manda, pa el caso Wink ) Como ventaja adicional cualquier salida del firmware que incluya acentos la verás como ISO manda.

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Mar 9 Dic 2008 - 21:23

Se me olvidó decirlo..... que no uso telnet ni wifi ni ftp....

Lo que hago es modificar el archivo de la carpeta hqlogos del skin enigma en el pendrive y lo llevo al USB1 del giga y desde Lemmi lanzo el vdr-RootFs.

Por eso necesito saber qué carácter pongo o cómo (y con qué) se cambia el nombre del archivo ese en el guindows.
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Videre el Mar 9 Dic 2008 - 22:21

He subido una nueva versión del fichero VDR-RootFS_y_Plugins_para_el_FW_VDR-NG-EM.zip al espacio de Asembla con la codificación correcta del archivo de Intereconomía y otros canales (de Cataluña). Bajate el nuevo archivo y prueba a grabar el logo de Intereconomía tal cual queda tras descomprimirlo. O mejor copia el zip al USB y prueba a descomprirlo desde el propio VDR con el plugin filebrowser y copia el fichero a su sitio, no vaya a ser que al descomprimir desde Windows no le guste y lo cambie.

Por cierto, los logos están un poco reguleros: los nombres de algunas cadenas ya no coinciden, las transparencias a veces no están en el sitio adecuado y algunos logos han cambiado. He renombrado los que sé que ya no se llaman así como TVE 1 -> La 1, etc.

Estaría bien que alguien le diese un buen repaso y lo subiese de nuevo mejorado.

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Krako el Mar 9 Dic 2008 - 22:49

Videre escribió:Estaría bien que alguien le diese un buen repaso y lo subiese de nuevo mejorado.
Estoy en ello....

Salu2, 🎅

_________________

M740: VDR-NG-EM 0.7 Pro (Última revisión) + Plugins
LAN 100Mbits + HDD USB WDElements 640Gb (3*ext2)

Wiki Foro Download
avatar
Krako
Moderador

Cantidad de envíos : 415
Fecha de inscripción : 25/06/2008
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Mar 9 Dic 2008 - 23:28

Videre escribió:...Bajate el nuevo archivo y prueba a grabar el logo de Intereconomía tal cual queda tras descomprimirlo. O mejor copia el zip al USB y prueba a descomprirlo desde el propio VDR con el plugin filebrowser y copia el fichero ...

Pues no me ha funcionado lo de grabar el logo tal cual se descompime. La otra opción de descomprimirlo desde el propio vdr no puedo hacerla porque no veo ninguna opción de descomprimir....

Gracias por el intento. Por mi parte seguiré investigando a ver si doy con la solución en cuyo caso os lo haré saber.

Un saludo.
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por pbr01 el Jue 11 Dic 2008 - 14:00

¿Y cambiandolo con el filebrowser? tiene que funcionar porque usa la misma tabla de caracteres.
Yo no tengo los logos, me aburrí de ellos pero lo mismo un día me los pongo otra vez.
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Jue 11 Dic 2008 - 15:59

pbr01 escribió:¿Y cambiandolo con el filebrowser? .....

En la versión que yo uso de vdr, la RootFS, la opción Filebrowse no deja hacer nada. Las opciones que tengo (y que no se para qué sirven) son: mark, unmark, source thread y other. Osea, nada para cambiar nombres de ficheros.

Un saludo.
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por pbr01 el Jue 11 Dic 2008 - 18:50

¿Y copiar tampoco? juer, no me acuerdo de viejas versiones pero si deja copiar...
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Jue 11 Dic 2008 - 18:53

Krako escribió:....

Krako, te he enviado un mensaje interno por mensajería. ¿Te ha llegado? Es que veo que el mensaje, tras redactarlo y darle a enviar se queda en "bandeja de envio" sin ninguna opción para poder enviar y en "elementos enviados" no hay nada. ¿Funciona el correo interno?
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por pbr01 el Jue 11 Dic 2008 - 19:07

Si, funciona. Creo que se queda ahí hasta que se lee.
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por EnStandby el Jue 11 Dic 2008 - 19:24

pbr01 escribió:Si, funciona. Creo que se queda ahí hasta que se lee.

Ah!, vale. Es que es la primera vez que lo uso y me ha parecido un poco confuso..... Esperaré..... Sleep

Gracias por la aclaración.
avatar
EnStandby

Cantidad de envíos : 15
Fecha de inscripción : 23/11/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Larrinbe el Jue 11 Dic 2008 - 21:55

Con el filebrowser lo de copiar y pegar funciona bien. Lo he empleado en alguna ocasión para los losgos, precisamente.

Hay una pequeña pega que ahora recuerdo. Para pegar en un directorio se debe crear previamente un subdirectorio en él, elegirlo y entonces dar la orden de pegar. De lo contrario lo pegado queda en el directorio superior. Después se borra el subdirectorio creado o se deja para futuras actuaciones (yo siempre lo borro y luego me cuesta recrearlo la siguiente vez. ¡que memoria!, pero no es difícil, sabiendo que es factible hacerlo).
avatar
Larrinbe
Betatester

Cantidad de envíos : 568
Fecha de inscripción : 05/07/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por cascaman el Dom 15 Feb 2009 - 22:08

Pues yo me he encontrado con el problema de las tildes. Está todo aparentemente bien, pero los logos que tienen nombres de archivos con tilde no me salen... Sad
avatar
cascaman

Cantidad de envíos : 123
Fecha de inscripción : 25/06/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Logos skin enigma

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 1 de 2. 1, 2  Siguiente

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.