Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Comprobación del disco tras un apagado

Ver el tema anterior Ver el tema siguiente Ir abajo

Comprobación del disco tras un apagado

Mensaje por travelfun el Vie 30 Ene 2009 - 22:11

Desde que instalé el VDR, por aquello de la costumbre, lo configuré en apagado rápido. Todo muy bien, excepto que si quería apagar totalmente el Giga la única opción que tenía (que yo sepa) era la tecla azul en "configuración firmware", lo que siempre me provocaba una comprobación del disco en el rearranque.

Buscando llegué a la recomendación del sleep 5 en el desmontaje y montaje, sin resultado. Cambié el disco por si no era compatible, sin resultado .... hasta que decidí cambiar la configuración a apagado total.

Y con apagado total me para y arranca sin problemas, pero lo que me ha llamado la atención es que si, nuevamente, utilizo la tecla azul para reiniciar, al rearrancar vuelve a hacer la comprobación.

Entonces ¿que diferencia hay entre el apagado total (con el boton de power) y el apagado (reinicio) con la tecla azul?.

Si no hay ninguna ¿puede ser que el tiempo de la pregunta de comprobación de apagado actue como un sleep más largo y por eso funcione bien?

Gracias


Última edición por travelfun el Vie 30 Ene 2009 - 22:12, editado 1 vez (Razón : Lo siento, pero he abierto el post donde no debía. Por favor, que alguien arregle mi desaguisado)

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por bittor el Vie 30 Ene 2009 - 22:36

travelfun escribió:Desde que instalé el VDR, por aquello de la
costumbre, lo configuré en apagado rápido. Todo muy bien, excepto que
si quería apagar totalmente el Giga la única opción que tenía (que yo
sepa) era la tecla azul en "configuración firmware", lo que siempre me
provocaba una comprobación del disco en el rearranque.
Ese botón
azul reinicia (no apaga), si lo que quieres es apagar te puedes crear
una macro en el archivo /etc/vdr/keymacros.conf que cambie la
configuración del apagado rápido para hacer un apagado completo.
Sería algo así en el botón ? de ayuda (es un ejemplo):
Código:
User1 Menu 5 2 3 Down Down Right OK Power
Son las pulsaciones que haces en el mando, primero el Menú, luego el
número de configuración que es el cinco, después el dos que es el de
Configuración VDR, luego el tres que sería donde estuviera el apagado
rápido, después bajas dos veces y derecha para cambiar la opción,
aceptas con el OK y apagas.

Si lo tienes en apagado rápido y quieres hacer el apagado total le das
a la ayuda, y la siguiente vez que quieras hacer el apagado rápido le
tendrás que dar a la ayuda porque tendrás establecido el apagado total.

Espero que se me haya entendido.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por travelfun el Vie 30 Ene 2009 - 23:18

El sistema que apuntas con la macro me queda claro.

Lo que se me sigue escapando es el matiz entre apagar y reiniciar (que yo entiendo como apagar+encender). Si en los dos casos la parte de "apagar" fuera identica el resultado en el encendido lo sería también, pero no es así.

¿O debo entender "reiniciar" como un cierre no ordenado?, en cuyo caso si que es lógico que detecte que el disco no se desmontó correctamente y lo verifique.

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por bittor el Vie 30 Ene 2009 - 23:45

El cambio entre apagar y reiniciar es muy pequeño, básicamente hacen lo mismo y por lo visto a tu disco duro no le sienta bien.
Todo apunta que en el reinicio no le da tiempo a desmontar el disco correctamente y el sleep no te funciona porque se fuerza el reinicio y si tarda mucho en desmontarse no le da tiempo.

Tendrás que editar el archivo /etc/rc.halt y subir los valores 3 y 10 para que el reinicio sea más lento:
Código:
    action1="reboot 3 10"
    action2="reboot 3 10"
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por travelfun el Sáb 31 Ene 2009 - 14:39

bittor escribió:El cambio entre apagar y reiniciar es muy pequeño, básicamente hacen lo mismo y por lo visto a tu disco duro no le sienta bien.
Todo apunta que en el reinicio no le da tiempo a desmontar el disco correctamente y el sleep no te funciona porque se fuerza el reinicio y si tarda mucho en desmontarse no le da tiempo.

Tendrás que editar el archivo /etc/rc.halt y subir los valores 3 y 10 para que el reinicio sea más lento:
Código:
 action1="reboot 3 10"
action2="reboot 3 10"

Gracias, bittor. He cambiado los dos valores en el script al doble y sigue igual. De todas formas ya era más una cuestión de entender la diferencia entre las dos cosas que de necesidad, porque, al menos de momento voy a dejarlo en apagado total (al fin y al cabo es muy rápido). Si más adelante quiero cambiar ya tengo tu macro.

Ah, por cierto, que cuando digo dejarlo, debo ya decirlo en plural, puesto que ya he pasado el segundo Giga a VDR.

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por bittor el Sáb 31 Ene 2009 - 14:58

Puedes mirar el archivo /var/log/messages a ver si el disco se desmonta correctamente o da algún error.
Busca la línea que ponga "usbautomounter".
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por travelfun el Sáb 31 Ene 2009 - 16:22

Este es el resultado:

Código:

Jan 1 05:50:36 VDR1 daemon.info usbautomounter[81]: usb auto mounter started in auto mode
Jan 1 05:50:36 VDR1 daemon.info usbautomounter[81]: ext2 partition '/dev/sda1' with 3053568 inodes and 48839600 blocks of size 4096 found.
Jan 1 05:50:36 VDR1 daemon.info usbautomounter[81]: Device '/dev/sda1' is unclean needs checking
Jan 1 05:50:36 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': e2fsck 1.40 (29-Jun-2007)
Jan 1 05:50:37 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': VDR1 was not cleanly unmounted, check forced.
Jan 1 05:50:37 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Pass 1: Checking inodes, blocks, and sizes
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Pass 2: Checking directory structure
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Pass 3: Checking directory connectivity
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Pass 4: Checking reference counts
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Inode 801 (...) has invalid mode (00).
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Clear? yes
Jan 1 05:54:23 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2':
Jan 1 05:54:50 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Pass 5: Checking group summary information
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Free inodes count wrong for group #0 (2038, counted=2037).
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Fix? yes
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2':
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Free inodes count wrong (3053558, counted=3053557).
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': Fix? yes
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2':
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2':
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': VDR1: ***** FILE SYSTEM WAS MODIFIED *****
Jan 1 05:56:08 VDR1 daemon.info usbautomounter[81]: output of '/sbin/fsck.ext2': VDR1: 11/3053568 files (9.1% non-contiguous), 113787/48839600 blocks
Jan 1 05:56:19 VDR1 daemon.warn usbautomounter[81]: Command /sbin/fsck.ext2 exits with status 1
Jan 1 05:56:22 VDR1 daemon.info usbautomounter[81]: usb auto mounter finished

está claro que no solo detecta que fué desmontado incorrectamente. sino que realmente encuentra errores.

Lo he probado con el Giga en el que acabo de instalar el VDR y que estaba formateado siguiendo las recomendaciones del foro.

El disco es distinto del que utilizo en el otro Giga, pero la caja es, en ambos un modelo de Conceptronic que ya tiene unos años.

Y en este Giga, al igual que en el otro, el apagado completo no da ningún problema.

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por pbr01 el Sáb 31 Ene 2009 - 17:09

Juas, claro que se ve que al arrancar detecta algo malo, lo interesante es lo anterior para ver si sale algo raro al apagar.
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por travelfun el Sáb 31 Ene 2009 - 17:59

pbr01 escribió:Juas, claro que se ve que al arrancar detecta algo malo, lo interesante es lo anterior para ver si sale algo raro al apagar.

Ya lo se, pero esto es lo que hay, porque al arrancar machaca el log anterior. Cuando me instale el Ubuntu volveré a probar y llevaré el disco al PC para ver el log del cierre, pero de momento no puedo hacer más

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por pbr01 el Sáb 31 Ene 2009 - 19:26

Pues es verdad, no me había dado cuenta.
Corregir si parece que corrige.
De todas formas estás con la stable 0.3, espera a la 0.4 para windows que viene en éstos días, mañana o pasado o muy pronto.
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por travelfun el Dom 1 Feb 2009 - 11:38

Bueno, pues ya me he instalado la versión 0.4, y problema resuelto. :cheers: :cheers: :cheers:

Gracias a todos.

travelfun

Cantidad de envíos : 51
Fecha de inscripción : 25/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por garbas el Sáb 21 Feb 2009 - 18:32

Me está pasando lo mismo con mi disco duro, un Seagate FreeAgent de 500 GB.
A travelfun se le solucionó instalando la versión 0.4, pero yo ya tengo esa versión.

El asunto es que también me ha pasado al apagarse automáticamente tras finalizar una grabación que se realizó estando en apagado total, y ahí se supone que debería hacer lo mismo que si lo apago sin más del mando ¿no?

No sé muy bien qué probar, porque cada prueba requiere chequear el disco en un PC, proceso que dura cerca de una hora.

Por cierto, ¿para que sirve la opción wait del comando reboot del pic_tool?
¿Un sleep justo después del umount del rc.local podría servir de algo?

garbas
Betatester

Cantidad de envíos : 101
Fecha de inscripción : 18/09/2008
Edad : 42

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por pbr01 el Sáb 21 Feb 2009 - 18:48

Seguramente sirva, porque seguro que es ese el problema, que tarda más en desmontarse. Yo en la 0.3 creo que me puse un sync, pero hace taaanto tiempo...
avatar
pbr01
Betatester

Cantidad de envíos : 489
Fecha de inscripción : 11/08/2008
Edad : 42
Localización : Valladolid

Ver perfil de usuario http://m7x0.co.cc

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por garbas el Sáb 21 Feb 2009 - 18:51

En el rc.halt de la 0.4 hay un sync justo antes del umount -a -l (al menos en el que tengo yo).

También he leído aquí que eliminar el spindown podría resolver el problema. Voy a ver si encuentro esa opción entre las miles que hay para configurar.

garbas
Betatester

Cantidad de envíos : 101
Fecha de inscripción : 18/09/2008
Edad : 42

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por jb el Sáb 21 Feb 2009 - 19:24

garbas escribió:Me está pasando lo mismo con mi disco duro, un Seagate FreeAgent de 500 GB.
A travelfun se le solucionó instalando la versión 0.4, pero yo ya tengo esa versión.

El asunto es que también me ha pasado al apagarse automáticamente tras finalizar una grabación que se realizó estando en apagado total, y ahí se supone que debería hacer lo mismo que si lo apago sin más del mando ¿no?

No sé muy bien qué probar, porque cada prueba requiere chequear el disco en un PC, proceso que dura cerca de una hora.

Por cierto, ¿para que sirve la opción wait del comando reboot del pic_tool?
¿Un sleep justo después del umount del rc.local podría servir de algo?

¿puede servirte esto?
http://vdr-m7x0.foroactivo.com.es/manuales-y-otros-documentos-de-ayuda-f7/discos-que-funcionan-no-funcionan-con-vdr-ng-em-t52-45.htm#4151
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 48
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por garbas el Sáb 21 Feb 2009 - 20:04

De momento he desactivado el apagado automático del disco (supongo que eso es el spindown del que habláis).

He hecho una prueba de reinicio desde el menú y ha ido bien (no ha chequeado el disco).

Tendré que hacer las pruebas. Lo malo es que esto va a hacer que el disco no se pare nunca. Aunque viniendo de un firmware con timeshift constante y sin apagar el equipo por las noches, supongo que ya estará acostumbrado ;-)

Cuando tenga algo más de tiempo (ahora el niño me reclama la tele) haré alguna prueba con los sleeps. Mientras observaré cómo se comporta con esa configuración con el uso normal.

Muchas gracias por las sugerencias.

garbas
Betatester

Cantidad de envíos : 101
Fecha de inscripción : 18/09/2008
Edad : 42

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobación del disco tras un apagado

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.