Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



no me monta unidades USB (algunas)

Ver el tema anterior Ver el tema siguiente Ir abajo

no me monta unidades USB (algunas)

Mensaje por gigatron el Mar 28 Abr 2009 - 13:16

Os explico un poco rápido lo que me pasa, pero pondré el log después.

He actualizado ayer el FW (compilando desde el SVN) porque tenía un problema que sigo teniendo igualmente, y se trata de que el giga NO me monta dos de mis unidades USB.

Las que NO monta:

Un pendrive de 4GB formateado en fat32
Un disco duro de 40GB formateado en ext2 (que antes sí me leía, cuando tenía VDR clásico, hasta hoy no había probado con VDR-NG)
Un disco duro de 300 GB formateado en fat32 (que antes sí leía también, en VDR clásico).

En el log me pareció ver algo de "invalid fat boot sector ¿is a vfat filesystem?" o algo parecido, ya lo confirmaré.

Las que SI monta:
Mi Freeagent querido de 500GB
Un pen-lector de tarjetas con una SD de 2 GB en Fat16 (desde ahí actualicé el FW).

El caso es que quería usar boxamp desde otro disco duro, pero veo que no hay manera.

Ah! Todos los discos funcionan bien en ordenadores bajo windows y linux.
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por bittor el Mar 28 Abr 2009 - 16:54

El BoxAmp no funciona con los últimos firmwares VDR-NG, pero en principio ya puedes probar el plugin MP3 añadiéndolo en el .config.

Que esos discos se monten en Windows, Linux y otros firmwares distintos al VDR-NG no asegura al 100% que esos discos estén funcionando correctamente y no tengan algún problema o error.
Esto que puede parecer obvio no lo es, ya que otros sistemas pueden estar montando un disco que tiene un error y al escribir dañar completamente el sistema de archivos perdiendo todos los datos del disco y VDR-NG impide montarlo para evitar problemas.

Leyendo el mensaje sobre el FAT parece que está dañado el sector de arranque y para regenerarlo tendrás que ejecutar "FDISK /MBR" en un Windows.

Habría que saber el mensaje de error con el disco ext2.

Entiendo que son problemas de disco porque el VDR-NG soporta tanto FAT como ext2.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por gigatron el Mar 28 Abr 2009 - 19:39

Pues te tengo que decir que BoxAmp sí que me funciona en el último FW; eso sí, a veces hace cosas raras o se bloquea, pero me funciona.

Voy a probar el plugin de MP3... ¿puedo compilarlo suelto? Es que volver a compilar todo el firm... ¿cómo hago para compilar sólo el plugin para meterlo como externo?

Con los discos duros VDR a veces es caprichoso, ya que en su día con el FreeAgent he tenido que hacer varios formateos hasta que le "gustó"... Pero será lo que tú dices, de que tiene que estar "perfecto" para "atreverse" a montarlo.

Algunos datos: El pen que no monta (en fat32), es un disco de windows XP con su MBR preparado para arrancar... Así que "corrupto" no está, ya que funciona para su cometido en un ordenador (me puse a hacer pruebas con el Asus eee, aunque no le metí windows al final ni para probar).

El disco en ext2 de 40GB no lo llega a montar, lo máximo que puede hacer es detectarlo (muy pocas veces) cuando lo "obligo" a montar desde órdenes, y en ese caso lo que dice es que necesita ser comprobado, lo comprueba, termina con éxito, pero luego sigue sin montarlo.

En fín, mañana si tengo tiempo lo primero que hago es intentar montarlos y sacar el log, y lo pego aquí, pero de momento me interesa saber cómo compilar los plugins sueltos (me interesa el de dvmon y el mp3)

Por cierto, a los que lo hayáis probado... ¿qué tal el de mp3?

Ah! y gracias por tu tiempo bittor
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por gigatron el Mar 28 Abr 2009 - 19:57

Me contesto a mi mismo:

Compilar plugins (si ya has compilado el FW antes):

cd ~/VDR-NG-EM
svn update
sudo rm -r /VDR-NG
sudo ./make-plugins
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por mtps37 el Miér 29 Abr 2009 - 23:57

Hola.

Yo he tenido los mismos problemas con mi pendrive, y he descubierto cuál es el problema y su solución: si usamos un pendrive formateado como viene de fábrica, o tras formatearlo en Windows, lo tendremos con FAT y SIN tabla de particiones.

En mi caso el pendrive se montaba sobre el dispositivo Linux /dev/sdc, y no sobre /dev/sdc1. Esto normalmente no da problemas ni en Windows ni Linux, pero se ve que a VDR no le gusta esto.

La solución consiste en crearle una tabla de particiones al pendrive en la que se cree un volumen FAT por ejemplo. En Windows existen herramientas como Partition Magic y en Linux está el QTParted por ejemplo. También se puede hacer con fdisk y mkdosfs. Así lo hice yo:

$ sudo fdisk /dev/sdc

Luego le dáis a la opción o (crear tabla de particiones DOS vacía).
Luego a n (crear nueva partición)
Después t, para cambiar el tipo de partición. Yo le indiqué FAT32.
Finalmente, w (para grabar los cambios).

Después de esto hay que generar el sistema de archivos para el pendrive:
$ sudo mkdosfs -c -F 32 -n TRAVELLER /dev/sdc1

Con esto me voy al gigaset y ya me reconoce el pendrive.


Un saludo

mtps37

Cantidad de envíos : 163
Fecha de inscripción : 20/01/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por gigatron el Jue 30 Abr 2009 - 7:46

Es cierto, con mi disco duro en su día he tenido que crear una tabla primero para que me leyera el formato.

De todas maneras, con el disco duro que tengo en FAT32 (el de los mp3) ya solucioné el problema (era el puto cable, si si, funcionaba e todas partes pero con el Giga el cable hacía invisible mi disco duro), y ahora ya lo monta... Aunque el Boxamp no lo quiere... Sad Si pongo su ruta para los MP3 se inicia, queda la pantalla en negro, y se sale a VDR otra vez... Y sin embargo, si pongo la ruta en FreeAgent (mi disco principal, en ext3), entonces inicia y me muestra y reproduce los mp3...
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: no me monta unidades USB (algunas)

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.