Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Comprobar sistema de archivos...

Ver el tema anterior Ver el tema siguiente Ir abajo

Comprobar sistema de archivos...

Mensaje por Tonet el Mar 25 Ago 2009 - 15:45

Hola,

Despues de unas semanas con este firm (598), el sistema me esta yendo perfectamente. Desde hace unos dias, cada vez que le doy a apagar, me sale el mensaje de que lleva mucho tiempo sin comprobar el disco /dev/sda1/ (el unico que tiene) y se pone a chequearlo.

El problema, es que parece que no lo termina, o por lo menos que no lo hace satisfactoriamente.

El disco duro es un maxtor de 160GB, relativamente nuevo. Funciona bien, no hace ruido, lo monta, desmonta y para bien, grabaciones bien, y hasta ahora no me habia dado problemas.

He probado a hacer un testeo desde Configuracion->Ordenes->Discos Duros, y va avanzando el progreso, y se queda al 90%... de ahi no pasa. No tengo red, por lo que no se si hay alguna forma de comprobar algunos log para ver mensajes de error.

He hecho otra cosa, he montado otro disco que tengo exactamente igual, y al formatearlo desde el giba, funciona bien tambien, pero al ir a testearlo, le pasa lo mismo, que se queda al 90% y no avanza.

No se si pueda ser un error de los discos, que fallen los dos, y solo fallen en esos chequeos. Tampoco tengo linux, por lo que no puedo chequearlos en el ordenador sin formatearlos en fat32 o ntfs. Desde windows en ntfs me dice que todo esta bien, no se queja de sectores erroneos.

Bueno, a ver si alguien me da alguna idea. Si conoceis alguna utilidad para chequear discos ext desde windows, o algun live cd o algo para arrancar linux y poder comprobarlos, me vendria bien. Tambien he pensado incluso, si existe opcion de desactivar este chequeo automatico porque lleve mucho tiempo sin mirar el disco... el dia que se rompa lo tiro y pongo otro y listo.

Gracias anticipadas.

Tonet

Cantidad de envíos : 6
Fecha de inscripción : 22/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por yeahhh el Mar 25 Ago 2009 - 16:24

Posiblemente se quede sin memoria al hacer la comprobación, aunque normalmente con discos de 160gb hace la comprobación sin problemas.

Como livecd puedes usar cualquier de linux, te recomendaría (por ejemplo) un ubuntu 9.04.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por Tonet el Mar 25 Ago 2009 - 17:21

Vaya... pues no habia pensado en esa posibilidad de la memoria Sad

Desde el gigaset no hay posibilidad de formatear el disco en dos particiones ?

Tonet

Cantidad de envíos : 6
Fecha de inscripción : 22/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por yeahhh el Mar 25 Ago 2009 - 17:38

Es que en teoria con 160gb no tienes que tener ningún problema en verificar el disco, yo tengo un lacie de 160gb y me hace el escaneo perfectamente.
El formateo desde el menu ordenes hace particiones de 200gb (si mal no recuerdo) por si tienes discos más grandes, así que de 160gb solo te hará 1.
Lo que me extraña es lo que me decías de que no te hace la comprobación de otro que tienes de 160gb formateado desde el menu ordenes.

El fichero messages lo puedes ver con el plugin filebrowser, aunque no se si allí verás algún error.

Tu compilación creo que ya es capaz de hacer el escaneo del disco viendo la tele no? en ese caso, lanza la comprobación y cuando "pete" con el filebrowser te miras el fichero messages.

Igualmente te recomiendo compilar la última versión, hay unos cambios en la velocidad de disco abismales, casi casi se ha duplicado la velocidad de lectura/escritura.
Ya se que no es la solución al problema, pero bueno, no está de más ir más rápido no?

Un saludo.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por Tonet el Vie 28 Ago 2009 - 13:49

A ver te cuento... que entre vacaciones y los niños no me dejan hacer muchas pruebas.

Me esta dando la sensacion de que el problema sea mio, de que no configuro algo bien. No controlo casi nada de linux, y algunas opciones de los menus, lo mismo estoy metiendo la pata.

Mira, he probado con dos discos Maxtor de 160 GB, y 2 seagate, 1 de 120 y otro de 160 GB, con identicos resultados.

El chequeo me lo hace mientras veo la tele, pero nada mas darle a hacerlo, sale un mensaje fugazmente que dice, error desmontando disco /dev/sda1. Se pone a chequear, y cuando llega al 90% la luz de actividad del disco se para, y tras unos 5 minutos mas, dice error chequeando disco, o algo asi.

Sin embargo al apagar el gigaset, me desmonta bien el disco, pues veo que se enciende la luz de actividad del disco, este se para, y 3 segundos despues el gigaset se apaga. Incluso, al arrancar, no se queja de que el disco este mal apagado.

No soy capaz de encontrar el archivo messages Sad Por esto pienso que algun parametro lo tendre mal puesto y no encuentra los directorios o particiones apropiados.

En el directorio de configuracion de apagado de discos usb, hay que poner el nombre del disco, pero no se si tengo que poner /dev/sda, /dev/sda1 o ponerlo con comillas " o '

En fin un lio. Como decia en uno de mis post anteriores, creo que seria mas facil intentar desactivar el chequeo que hace por haber pasado mucho tiempo sin hacer chequeo, si se puede, no lo se, y cuando deje de funcionar pues nada, lo tiro.

Gracias por vuestras respuestas.

Tonet

Cantidad de envíos : 6
Fecha de inscripción : 22/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por bittor el Vie 28 Ago 2009 - 14:02

Tonet escribió:No soy capaz de encontrar el archivo messages Sad Por esto pienso que algun parametro lo tendre mal puesto y no encuentra los directorios o particiones apropiados.
Está en el directorio /var/log/messages pero si usas una versión Lite tendrás que activar el log:
http://www.assembla.com/wiki/show/VDR-M7x0/Recomendaciones_y_trucos#lite_log

Tonet escribió:En fin un lio. Como decia en uno de mis post anteriores, creo que seria mas facil intentar desactivar el chequeo que hace por haber pasado mucho tiempo sin hacer chequeo, si se puede, no lo se, y cuando deje de funcionar pues nada, lo tiro.
Se pueden desactivar las comprobaciones periódicas del disco pero si hay errores al desmontar no se puede hacer nada más que poner una espera después de desmontar el disco (hay que modificar los scripts del firm).
avatar
bittor
Desarrollador

Cantidad de envíos : 3632
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Comprobar sistema de archivos...

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.