Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Ver el tema anterior Ver el tema siguiente Ir abajo

PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Vie 11 Dic 2009 - 8:40

Hola a todos,

Hace un año que tengo instalada la versión 0.4, y la verdad es que va muy bien. Al final me he decidido a instalar la versión 0.5, lo cual no me ha dado ningún problema excepto lo siguiente:
- Si miro la información del sistema me dice que continua siendo 0.4 (he probado a hacer un factory reset, pero no se si lo estoy haciendo en el orden correcto: primero realizar el factory reset y despues instalar el firmware o viceversa). Lo cierto es que no hay manera de que me diga que es la versión 0.5.
- El segundo problema que me he encontrado es que no me reconoce los discos USB. No me reconoce el original que venía con el equipo (LaCie 160Gb) ni tampoco me reconoce el pen que he utilizado para instalar el firmware. Sin embargo si vuelvo a instalar la versión 0.4 me lo reconoce todo sin problemas.

Creo que debe de ser un problema de la secuencia que realizo para la instalación del firmware, pero no consigo que acabe de funcionar y tengo que volver a la 0.4.

Gracias por vuestra ayuda,

NOTA: Independientemente de estos problemillas tengo que felicitaros, ya que el equipo funciona realmente bien.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por bittor el Vie 11 Dic 2009 - 9:14

Entiendo que has generado el firmware desde Windows ¿no?.
¿lo has hecho en un directorio nuevo o donde generaste el anterior 0.4?
¿versión Lite o Pro?

En el directorio donde lo hayas generado, mira el archivo:
temp\rootfs_dir_m740_pro\etc\fw-version

o si es una Lite:
temp\rootfs_dir_m740_lite\etc\fw-version

a ver qué versión pone.

Puedes hacer el factory reset antes o después de instalar el firmware, pero es más rápido hacerlo antes porque para hacerlo después estás obligado a hacer los 4 apagados y si lo haces antes es instalar y ya no hay que hacer nada.
¿el factory reset lo haces desde el menú de los 4 apagados?
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Vie 11 Dic 2009 - 15:23

Efectivamente lo he generado desde Windows, en otra carpeta diferente de la 0.4, y en versión Pro.

En el archivo pone lo siguiente:
VDR-NG-EM 0.5 Pro
SVN EM 598
SVN TC-o7o 402
SVN plugins 591
SVN webif 597

El procedimiento que he seguido ha sido:
- Generar el archivo .wsw
- Desde el menú órdenes he accedido al menu de rescate (4 apagados)
- Factory reset
- Instalo la versión 0.5 desde el menu de rescate

Creo que no me dejo nada.

Gracias

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por Posix el Vie 11 Dic 2009 - 18:20

Yo nunca uso el .wsw, siempre uso el .ofi que ya incluye el factory reset después de instalar. Pero tengo una duda:

Yo pesaba que el factory reset debe hacerse después de instalar. Si se hace antes, se regenera el directorio /etc de la versión antigua.

Pero esta claro que bittor sabe mucho más que yo.

_________________
VDR-NG-EM 0.7 R1084 - WD Elements 1TB ext3
VDR-NG-EM 0.7 R1048 - WD Elements 250GB ext3
swap, samba, VPN, mediatomb, uShare, nfsd
avatar
Posix
Desarrollador

Cantidad de envíos : 691
Fecha de inscripción : 05/11/2008
Edad : 50
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Vie 11 Dic 2009 - 20:37

La verdad es que he probado con el .wsw y con el .ofi y en ambos casos me hace lo mismo.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por yeahhh el Vie 11 Dic 2009 - 23:45

El .ofi generado por windows incluye el FR?
Yo siempre creo el directorio /rw-flash/SI para que cuando arranque haga el factory reset.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 9:30

He visto que en los directorios creados por windows hay uno que se llama /rw-flash, pero esta vacío. Lo que tengo que crear es una carpeta que se llame SI????? con el explorador de windows????
Supongo además que la tengo que crear en algún momento antes de que se genere el .ofi.

Gracias por todo,

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por yeahhh el Sáb 12 Dic 2009 - 9:37

No, te explico lo que yo hago (que igual hay cosas que ya se hacen, pero yo lo hago asi)
Teniendo un vdr instalado hago lo siguiente:
Copio el .ofi generado dentro del giga en /var/tmp
Le doy permisos de ejecucion con el comando chmod +x
Creo el directorio /rw-flash/SI
desmonto el disco con umount /dev/sda (si mal no recuerdo)
hago un kill-vdr
Y una vez matado vdr, te vas al directorio /var/tmp
y con ./nombrefirmware.ofi se te instala el firm, se reinicia, hace el factory reset, etc etc...

Evidentemente todo esto por telnet.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por bittor el Sáb 12 Dic 2009 - 10:31

susomi escribió:El procedimiento que he seguido ha sido:
- Generar el archivo .wsw
- Desde el menú órdenes he accedido al menu de rescate (4 apagados)
- Factory reset
- Instalo la versión 0.5 desde el menu de rescate
Pues es todo correcto y debería funcionar bien.
¿La primera vez que arranca te salen unos mensajes por pantalla indicando que está haciendo el factory reset?
¿has mirado el archivo /var/log/messages a ver si hay algún problema?

yeahhh escribió:No, te explico lo que yo hago (que igual hay cosas que ya se hacen, pero yo lo hago asi)
Hay un método más simple y seguro porque en tu caso no desmontas /etc ni /rw-flash.
Copias el ofi a /var/tmp/new-fw.ofi (tiene que tener ese nombre aunque se puede configurar en el parámetro fw_update_file de /etc/rc.local.conf) y si lo haces desde Linux ya tendrá los permisos de ejecución, en caso contrario se ejecuta "chmod +x /var/tmp/new-fw.ofi" y finalmente "ash /etc/rc.halt".
Así se cierra el VDR, se guarda la EPG, se desmonta el disco duro, /etc y /rw-flash y se establecen las variables de idioma para que el ofi se instale según el idioma que esté configurado en el VDR.

El directorio "/rw-flash/SI" sólo es necesario crearlo si ha cambiado algo bajo /etc, si por ejemplo hay cambios del kernel o se actualiza el servidor de FTP o algún otro programa no es necesario crearlo.

El firmware ofi no hace un factory reset por sí solo, hay que crear el directorio /rw-flash/SI (pero una vez que el firmware se está ejecutando, no en el firmware).
Los OFI se pueden instalar desde el plugin FileBrowser (Explorador de archivos) que ya crea ese directorio para hacer el factory reset y cuando se apaga se instalará correctamente.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 13:37

[quote="susomi"]
bittor escribió:
Pues es todo correcto y debería funcionar bien.
¿La primera vez que arranca te salen unos mensajes por pantalla indicando que está haciendo el factory reset?
¿has mirado el archivo /var/log/messages a ver si hay algún problema?


Hola,

Cuando hago el factory reset desde el menú dice que lo ha hecho y vuelve al menu de rescate, instalo el .wsw desde el, y la primera vez que arranca la versión 0.5 no me sale ningún mensaje de que esté realizando el factory reset.

El archivo /var/log/messages no lo he podido ver ya que no lo puedo copiar a ningún sitio porque no me reconoce ni el disco duro ni el pen. Supongo que igual si que lo puedo ver via telnet. A ver si hoy tengo un rato y me puedo dedicar un poco mas al tema y descubro algo.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por yeahhh el Sáb 12 Dic 2009 - 13:39

Si entras por telnet, creas el directorio SI dentro de rw-flash y apagas y enciendes, se hace un factory reset si o si.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 39
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por Posix el Sáb 12 Dic 2009 - 14:58

[quote="susomi"]
susomi escribió:
bittor escribió:
Pues es todo correcto y debería funcionar bien.
¿La primera vez que arranca te salen unos mensajes por pantalla indicando que está haciendo el factory reset?
¿has mirado el archivo /var/log/messages a ver si hay algún problema?


Hola,

Cuando hago el factory reset desde el menú dice que lo ha hecho y vuelve al menu de rescate, instalo el .wsw desde el, y la primera vez que arranca la versión 0.5 no me sale ningún mensaje de que esté realizando el factory reset.

El archivo /var/log/messages no lo he podido ver ya que no lo puedo copiar a ningún sitio porque no me reconoce ni el disco duro ni el pen. Supongo que igual si que lo puedo ver via telnet. A ver si hoy tengo un rato y me puedo dedicar un poco mas al tema y descubro algo.

Vuelve a hacer un factory reset después de instalar aunque sea desde los 4 enchufados.

_________________
VDR-NG-EM 0.7 R1084 - WD Elements 1TB ext3
VDR-NG-EM 0.7 R1048 - WD Elements 250GB ext3
swap, samba, VPN, mediatomb, uShare, nfsd
avatar
Posix
Desarrollador

Cantidad de envíos : 691
Fecha de inscripción : 05/11/2008
Edad : 50
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 17:00

Hola a todos,

Una vez instalada la versión 0.5 he hecho un factory reset desde los 4 enchufazos y hace lo mismo.

También he intentado crear el directoria /rw-flash/SI a través de telnet, pero cuando ejecuto el comando el sistema me dice que no hay espacio suficiente, cuando realmente si que lo hay.

He descargado via telnet el archivo messages y os adjunto algunas cosillas a ver si sirve de algo.

Jan 1 01:01:29 m750 user.err vdr: [131] VDR version 1.4.7 m7x0 version Preview 2009-06-29 06:37 (o7o version: Edición Mejorada Pro 0.5 BETA) started
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-extrecmenu.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: unknown config parameter: NextWakeupTime = 1260309300
Jan 1 01:01:52 m750 user.err vdr: [147] EPGSearch: search timer update started
Jan 1 01:01:52 m750 user.err vdr: [147] ERROR: /etc/vdr/plugins/epgsearch/timersdone.conf.$$$: No space left on device
Jan 1 01:01:52 m750 user.err vdr: [147] EPGSearch: search timer update finished
Dec 12 16:44:30 m750 user.err vdr: [147] EPGSearch: search timer update started
Dec 12 16:44:31 m750 user.err vdr: [147] ERROR: /etc/vdr/plugins/epgsearch/timersdone.conf.$$$: No space left on device
Dec 12 16:44:31 m750 user.err vdr: [131] ERROR: /etc/vdr/epg.data.$$$: No space left on device
Dec 12 16:44:31 m750 user.err vdr: [131] ERROR (epg.c,1026): No space left on device
Dec 12 16:44:31 m750 user.err vdr: [131] ERROR: /etc/vdr/channels.conf.$$$: No space left on device
Dec 12 16:44:31 m750 user.err vdr: [131] ERROR: /etc/vdr/timers.conf.$$$: No space left on device
Dec 12 16:44:31 m750 user.err vdr: [147] EPGSearch: search timer update finished
Dec 12 16:44:31 m750 user.err vdr: [147] EPGSearch: check for timer conflicts
Dec 12 16:45:02 m750 daemon.info usbautomounter[173]: usb auto mounter started in auto mode
Dec 12 16:45:02 m750 daemon.info usbautomounter[173]: usb auto mounter finished

Como veis se repito mucho lo de "no space left on device".

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 17:32

Hola de nuevo a todos,

Creo que tengo buenas noticicas. Resulta que en el archivo messages entre otras cosas se quejaba de algunos plugins. Pues bien, he borrado los plugins que me daban error, he realizado un factory reset y al arrancar ¡sorpresa!, ya funciona todo correctamente. Ahora ya indica la versión correcta y reconoce los discos sin problema.

Creo que es una buena cosa para tener apuntada por ahi por si le pasa a alguien más. La verdad es que ya era una de esas pruebas por probar algo, pero ha habido suerte.

Ahora tengo que ponerme a revisar todo para ver que no haya nada mas extraño.

De nuevo gracias a todos.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por jb el Sáb 12 Dic 2009 - 17:35

Quizás sería bueno saber que plugins daban problemas por si puede ser interesante la información para acciones posteriores.
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 48
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 17:40

jb escribió:Quizás sería bueno saber que plugins daban problemas por si puede ser interesante la información para acciones posteriores.

Hola,

Estos son lo plugins que me daban fallo:
Jan 1 01:01:30 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-clock.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-extrecmenu.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-pictures.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-games.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-zaphistory.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched

Como ya os digo, ha silo eliminarlo y se ha solucionado todo.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 12 Dic 2009 - 17:54

jb escribió:Quizás sería bueno saber que plugins daban problemas por si puede ser interesante la información para acciones posteriores.

Adjunto la lista de los plugin que fallaban:

Jan 1 01:01:30 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-clock.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-extrecmenu.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-pictures.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-games.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched
Jan 1 01:01:31 m750 user.err vdr: [131] loading plugin: /var/vdr/lib/libvdr-zaphistory.so.1.4.5
Jan 1 01:01:31 m750 user.err vdr: [131] ERROR: O7O Toolchain-Version mismatched

Una vez borrados todo a funcionado correctamente.

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por bittor el Dom 13 Dic 2009 - 19:11

Eso es porque usabas plugins de la versión anterior.
Usa los nuevos plugins de la versión 0.5 y no tendrás ningún problema.


Última edición por bittor el Lun 14 Dic 2009 - 18:58, editado 1 vez (Razón : Corregir link)
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por susomi el Sáb 19 Dic 2009 - 13:49

bittor escribió:Eso es porque usabas plugins de la versión anterior.
Usa los nuevos plugins de la versión 0.5 y no tendrás ningún problema.

Hola,

Disculpad que no haya podido contestar hasta hoy, pero he tenido una semana muy liada en el trabajo.

Efectivamente el problema procedía de los plugins, ya que ahora he vuelto a instalar alguno de los plugins que antes provocaban el fallo, y ahora funcionan correctamente.

Gracias a todos por vuestra ayuda,

susomi

Cantidad de envíos : 16
Fecha de inscripción : 14/02/2009
Localización : Tarragona

Ver perfil de usuario

Volver arriba Ir abajo

Re: PROBLEMA CON LOS DISCOS USB EN VERSION 0.5

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.