Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Rendimiento de red

Ver el tema anterior Ver el tema siguiente Ir abajo

Rendimiento de red

Mensaje por Fran el Sáb 2 Ago 2008 - 12:54

Os cuento lo que me ha pasado. Tengo 2 M740 conectados a la LAN a través de sendos puntos de acceso Wifi. No tengo discos duros conectados via USB sino que los 2 graban en el mismo directorio de un disco en red. De ese modo puedo ver lo grabado en cualquiera de los 2.

Hasta que instale el VDR en uno de ellos el acceso via Wifi funcionaba bastante bien (anteriormente tenia la versión 2.3.61 instalada en ambos M740): podia grabar una cosa en el M740 y ver otra simultaneamente (al grabar 2 y ver otra a veces iba a trompicones debido al ancho de banda). Despues de instalar el VDR, me he dado cuenta que los requerimientos de ancho de banda que tiene son mayores ya que no he sido capaz de reproducir ninguna grabación sin que esta sin que se produzcan saltos de forma continua. He estado mirando por todos lados si habia alguna forma de optimizar el acceso. Modifique el fichero etc/fstab para que el acceso fuera via NFS o CIFS, como menos saltos pega en con NFS con esta configuración en concreto:

192.168.1.10:/nethdd/TV /var/media/v1 nfs rsize=8192,wsize=8192,nolock,intr 0 0

Cuando ya no supe que hacer probé a volver a instalar la version 2.3.61 para ver si de verdad era un tema del VDR o de la propia red y las grabaciones volvieron a verse con fluidez y sin saltos.

Os lo comento por si se os ocurre alguna prueba o reajuste de configuración que pueda y por si a los que estais participando en el desarrollo, tan brillantemente, os puede servir de ayuda para proximas versiones.

Fran

Cantidad de envíos : 10
Fecha de inscripción : 12/07/2008
Localización : Valdemorillo (Madrid)

Ver perfil de usuario

Volver arriba Ir abajo

Re: Rendimiento de red

Mensaje por bittor el Sáb 2 Ago 2008 - 18:28

Pues es un poco raro que te siga pasando con NFS ya que es más rápido (al consumir mucho menos ancho de banda) que CIFS.

¿pero el problema te surge al grabar y reproducir a la vez o sólo reproduciendo una grabación?
¿has mirado el archivo /var/log/messages?
puede que haya algún problema y se pierdan paquetes, porque los firmwares VDR-NG tienen parcheado el kernel para obtener mayores ratios de transferencia que con los firmwares wavebox, así que tendría que irte mejor que con el 2.03.61 y los archivos MPEG son los mismos por compatibilidad con los módulos no liberados.
avatar
bittor
Desarrollador

Cantidad de envíos : 3633
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Rendimiento de red

Mensaje por Fran el Lun 11 Ago 2008 - 13:06

Bittor, gracias por el interes.

El problema era al grabar y reproducir a la vez. Al final estuve probando con muchas de las opciones que hay al montar NFS, sobre todo con los parámetros rsize y wsize. La verdad es que con valores de 65536 iba bien, pero tenia el problema de que se me quedaba colgado.

Cuando ya no sabia que mas hacer, decidí revisar la configuración de la red wifi y moví la posición del router y de los AP intentando mejorar la señal y le he quitado la seguridad (el WPA ralentiza bastante y como no tengo vecinos, no me preocupa mucho). Ahora va bien y de hecho ya he instalado el VDR en los 2 M740 que tengo.

Muchas gracias por tu interes.

Fran

Cantidad de envíos : 10
Fecha de inscripción : 12/07/2008
Localización : Valdemorillo (Madrid)

Ver perfil de usuario

Volver arriba Ir abajo

Re: Rendimiento de red

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.