Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



plugin mp3, no me va

Ver el tema anterior Ver el tema siguiente Ir abajo

plugin mp3, no me va

Mensaje por gigatron el Mar 28 Abr 2009 - 20:56

Holas.

Hoy he compilado el último VDR desde el SVN, y hace unos minutos me compilé todos los plugins.

He probado el dvmon y mp3, y al principio el giga no me arrancaba, así que hice factory reset, restaurar configuración, y a volver a probar.

Luego probé sólo el plugin mp3, y lo mismo, no me arrancaba; a volver a empezar.

Luego probé sólo el dvmon, y ese sí que me funciona, así que descarto que se haya compilado mal.

¿a vosotros os funciona?

Más datos:
-No me anunció fallo con estos plugins al terminar la compilación.
-Mi firmware es PRO, y sí, seleccioné el tipo de FW al inicio de la configuración en 1 (LITE-PRO)
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por sblanco el Mar 28 Abr 2009 - 21:50

¿Desde cuando funciona el plugin mp3? Que yo sepa, no está operativo aún cuando compila, están trabajando en ello...

Saludos

sblanco

Cantidad de envíos : 84
Fecha de inscripción : 18/07/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por yeahhh el Mar 28 Abr 2009 - 21:53

Ese plugin no funciona hasta donde yo se.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 38
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por gigatron el Miér 29 Abr 2009 - 7:44

Pensaba que ya funcionaba, según el comentario, en otro hilo, de bittor:

bittor escribió:
El BoxAmp no funciona con los últimos firmwares VDR-NG, pero en
principio ya puedes probar el plugin MP3 añadiéndolo en el .config.

Claro que él se refiere (si no entiendo mal) a meterlo en la compilación del firm como plugin interno ¿me equivoco?
Y en ese caso... ¿es posible que funcione como interno y no como externo?

Bueno, a quienes están trabajando en ello mucho ánimo...
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por bittor el Miér 29 Abr 2009 - 9:37

Realmente el plugin MP3 ha funcionado desde que lo pusieron, el problema de que no compilara es debido a que hacían falta las librerías libres id3tag y mad.

Los archivos para compilar estas librerías en el firm sólo las han pasado al grupo de desarrollo alemán porque el plugin no estaba terminado y no querían peticiones de usuarios diciendo quiero que el plugin haga esto o lo otro o reporten fallos metiendo presión, pero cualquiera con unos mínimos conocimientos podía añadir estas librerías al firmware tal y como hemos hecho con otros programas en nuestro firmware mejorado.

Actualmente leí en los comentarios de su SVN que ya no hacían falta estas librerías por lo que entendía que ya se puede compilar sin errores, entonces ¿cual es el error que te da en /var/log/messages al cargar este plugin? (quizás te falte algún archivo de configuración o esté buscando archivos MP3 en el disco duro).
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por gigatron el Miér 29 Abr 2009 - 13:06

Pero no puedo acceder al var/log/messages porque el Giga se cuelga, no arranca y no tengo otra salida que hacer factory reset, que supongo que lo borra.

No creo que sea que busque archivos MP3, porque tengo bien pocos para probar (aunque no sé si hay que ponerlos en alguna ruta en especial, yo los tengo en /media/FreeAgent/music/), y en cualquier caso lo dejé cinco minutos y seguía sin resolverse y no parecía estar leyendo en el disco duro.

Si me falta algún archivo de configuración... ¿cuál será?
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por garbas el Miér 29 Abr 2009 - 15:16

gigatron escribió:Pero no puedo acceder al var/log/messages porque el Giga se cuelga, no arranca y no tengo otra salida que hacer factory reset, que supongo que lo borra.
Pero, para activar un plugin no es necesario reiniciar todo el Gigaset, sino sólo el VDR (¿o estoy equivocado?)
Puedes conectarte por telnet, ejecutar tail -f /var/log/messages, luego activar el plugin y reiniciar el VDR.
Así deberías poder ver los mensajes que se añadan al log hasta que se cuelgue.

garbas
Betatester

Cantidad de envíos : 101
Fecha de inscripción : 18/09/2008
Edad : 42

Ver perfil de usuario

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por bittor el Miér 29 Abr 2009 - 16:50

No sé que puede ser porque no lo he probado, pero en principio tendría que ir porque los desarrolladores alemanes lo están usando, aunque no sé si esta última versión que no necesita esas librerías que comentaba antes va bien del todo o está en proceso.

Dentro del plugin hay un directorio examples con un archivo llamado "mp3sources.conf" (tiene que estar en /etc/vdr/plugins), pero si se te cuelga no creo que sea porque le falta ese archivo.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por bittor el Lun 25 Mayo 2009 - 19:08

Me comunica Hanspeter que es un desarrollador del equipo open7x0.org que el plugin MP3 es una versión pre-alpha.
Ha sido modificado por Andreas Koch para que no necesite ninguna librería y entre WuddiwuppX2 y Hanspeter están arreglando el resto de cosas para que funcione correctamente en el VDR-M7x0, pero queda mucho por hacer todavía.

Para que funcione es necesario usar la última versión de andreas-unstable, que en nuestra versión VDR-NG-EM sería a partir de la revisión 552 del SVN (las versiones anteriores no funcionan).

El manual y el readme del plugin están actualizados a esta versión, así que pueden ser tomados de referencia para la configuración y el uso.

Yo todavía no lo he probado, pero a ver si alguien puede compilar la última versión y cuenta si le funciona.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por gigatron el Lun 25 Mayo 2009 - 21:16

Lo probaré y os cuento.

Saludos
avatar
gigatron
Betatester

Cantidad de envíos : 412
Fecha de inscripción : 03/07/2008
Edad : 36

Ver perfil de usuario http://www.nosolopixel.com

Volver arriba Ir abajo

Re: plugin mp3, no me va

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.