Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Harto del equipo

Ver el tema anterior Ver el tema siguiente Ir abajo

Harto del equipo

Mensaje por Ciclope el Dom 19 Jul 2009 - 12:03

Harto no, hartísimo.
Parecía que había encontrado un firm para el Giga estable y que prometía mucho, pero más de lo mismo. En lineas generales el Gigaset M740-750 es muy buen aparato cuando funciona como debe, pero falla más que la escopetas de feria.
Todos los días amanecía apagado (disco duro incluido) y hoy estaba como grabando algo (el disco no paraba de parpadear) y al encender el TV veo que no responde al mando, bueno sí, pero tarda como 15 o 20 segundos. Además indica que no hay espacio para grabación, cuando debía haber de sobra.
Procedí a reiniciarlo pero seguía igual, el disco no paraba de parpadear y al parecer no lo reconocía pues indicaba 0% de grabación y continuaba sin responder bien al mando. Lo desconecté de la red sin mejora por lo que opté a realizar un Factory Reset desde los 4 enchufados y ahora aparte de haberme desorganizado todo no me reconoce el HD y se ha quedado colgado al intentar desmontarlo.
En definitiva, creo que me pasaré al "club" de los que tuvieron un equipo de estos y desistieron de él. Por no hablar de la gente que no tiene ningún conocimiento de firm, de update, ni sabe de estos foros.

Ciclope

Cantidad de envíos : 21
Fecha de inscripción : 04/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por jb el Dom 19 Jul 2009 - 12:19

Creo, que como habrás visto en algún otro mensaje del foro la información cuando más amplia mejor. Comencemos por el contenido del fichero /var/log/messages, si lo posteas será muy posible que te puedan dar una solución, o al menos que te digan si lo tuyo no la tiene.

También sería interesante que indicases que plugins tienes activados, que marca de disco duro utilizas, versión que estás utilizando, etc.

Lo de que no te reconozca el HD puede ser por que se haya podido quedar mal desmontado ¿has tenido cortes de energía eléctrica?.

Ten en cuenta que lo que te ha pasado es rarísimo con este firm (no digo imposible por que es una palabra que no existe en mi vocabulario), pero los cuelgues con este firm no son ni mucho menos una tónica habitual.
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 47
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Posix el Dom 19 Jul 2009 - 12:33

Tiene toda la pinta de estar comprobando el disco después de un corte de electricidad.
En ese caso, cada 2 minutos más o menos muestra un mensaje de lo que está haciendo.
Si intentas apagarlo durante la comprobación, en realidad se queda en apagado rápido hasta que termina.
Si las particiones que tienes son grandes (más de 200 GB) se queda casi sin memoria y por eso responde tan lento al mando.
Si tienes acceso por red, intenta pasarnos el fichero /var/log/messages y podremos decirte algo con más seguridad.

Si le das una segunda oportunidad al bicho, seguro que te da muchas alegrias.

_________________
VDR-NG-EM 0.7 R1084 - WD Elements 1TB ext3
VDR-NG-EM 0.7 R1048 - WD Elements 250GB ext3
swap, samba, VPN, mediatomb, uShare, nfsd
avatar
Posix
Desarrollador

Cantidad de envíos : 691
Fecha de inscripción : 05/11/2008
Edad : 50
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por gotarron el Dom 19 Jul 2009 - 13:31

Comparto el consejo. Yo compré un m740 de segunda mano por lo que había leido por los foros. Lo pasé a un M750 y desde entonces, y con los firmwares que todos conocemos, aún con sus sorpresas me parecía un aparato formidable. Luego, con la obligación de pago de la sincroguía, opté por probar el VDR y ya no he tenido ningún cuelgue "inexplicable" y muy pocas veces, cuelgues por fallos en el disco duro que se han solucionado sin mayores quebraderos de cabeza.

A día de hoy tengo ya 3 gigas y, por prestaciones, no he encontrado nada igual. Comprueba que el disco duro que tienes funciona correctamente y no desistas que es un buen deco.

gotarron
Betatester

Cantidad de envíos : 69
Fecha de inscripción : 16/02/2009
Edad : 52
Localización : Zaragoza

Ver perfil de usuario http://www.tecnopuchero.es

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Ciclope el Dom 19 Jul 2009 - 14:27

Al final he podido recuperarlo pero a costa como dije de tener que configurarlo todo de nuevo. Probare la opción de guardar la configuración para en caso de necesitarlo de nuevo.
Creo que el problema ha venido por haber configurado mal el plugin de búsqueda por EPG. Hasta ahora estaba haciendo las programaciones desde la propia EPG e indicándole si me interesaba que grabara en serie modificando la opción del día.
Leyendo, ví que el plugin citado realizaba mejor esas programaciones y puse de esta forma dos o tres grabaciones, pero algo ocurrió y ha estado toda la noche grabando programas aleatorios de duración también aleatoria (de 2 minutos hasta 180).
Es una cosa bastante extraña, por eso cuando esta mañana vi que no estaba apagado, era porque estaba grabando ocupando los dos sintonizadores y parece que era el motivo que el mando no funcionara correctamente.
El log que tengo corresponde al día de hoy (realicé un Factory Reset) y es bastante largo, no sé si se podría sacar alguna conclusión con él.
Para poder volver a la normalidad tuve que hacer una comprobación del disco (2 particiones creadas desde el propio firm), y tras un largo rato parece que las recuperó.
De momento parece que todo está bien, por lo que pasaré del EPGSearch, que es lo que creo que me jodió el tema.
Ahora trataré de convencer de nuevo a la parienta que ya con este firm no habrá mas cuelgues. Smile

Ciclope

Cantidad de envíos : 21
Fecha de inscripción : 04/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por jb el Dom 19 Jul 2009 - 15:34

Probablemente configurases alguna grabación del epgsearch con algún comodín que grabase todo lo que pillase, con lo cual lo forzaste a trabajar a muchísima mayor capacidad de la que tiene el equipo.

Te pongo un ejemplo, imagina que por error haces una programación que te grabe todo lo que contenga la letra "a". Lo que te ocurrirá es que intentará grabar absolutamente todo, por que prácticamente cualquier línea de programación contiene esa letra, dejándote el equipo con una velocidad de respuesta bajísima por estar trabajando por encima de sus posibilidades.

La solución hubiese sido posible ojeando el messages y eliminando la programación, cuestión de un par de minutos, pero desenchufar y volver a enchufar lo único que hizo fue dejar el disco duro mal y además al volver a arrancar intentaría de nuevo programar todo y grabarlo todo.

Espero que todo vaya bien a partir de ahora.
Salu2
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 47
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Ciclope el Dom 19 Jul 2009 - 18:51

jb escribió:Probablemente configurases alguna grabación del epgsearch con algún comodín que grabase todo lo que pillase, con lo cual lo forzaste a trabajar a muchísima mayor capacidad de la que tiene el equipo.
No utilicé comodines, sólo puse "4400" y "Bricoman". Pero algo debió "entender" mal.

jb escribió:La solución hubiese sido posible ojeando el messages y eliminando la programación, cuestión de un par de minutos, pero desenchufar y volver a enchufar lo único que hizo fue dejar el disco duro mal y además al volver a arrancar intentaría de nuevo programar todo y grabarlo todo.
Es que reaccionaba lentísimo al mando e incluso llego a quedarse totalmente bloqueado, sin opción a poder desprogramar. Imagino que al desconectarlo y volver a conectarlo fué ya lo que lo dejó totalmente kaput.

jb escribió:Espero que todo vaya bien a partir de ahora.
Salu2
Lo mismo espero, además es de agradecer que ante cualquier problema esteis tan atentos. Un par de cervezas como mínimo os habeis ganado, aunque las virtuales no sientan tan bien Wink
Gracias a todos.

Ciclope

Cantidad de envíos : 21
Fecha de inscripción : 04/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por flashmcarthur el Dom 19 Jul 2009 - 20:38

El tema del EPGSearch es uno de los chungos, sobretodo con el otro firm, alguna vez tuve que borrar las programaciones que hacian la llamada al mismo porque lo fritaban, y es que como es tan "buscon" ralentiza el sistema hasta colapsarlo.

Algun timeout para el EPGSeach que si se pilla o el proceso supera x tiempo, que eliminará la busqueda que lo cuelga, seria un parche que evitaria estas situaciones.

flashmcarthur

Cantidad de envíos : 26
Fecha de inscripción : 17/01/2009
Edad : 39

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por bittor el Lun 20 Jul 2009 - 9:58

El EPGSearch no tiene ningún problema, en todo caso el problema es del usuario que hace búsquedas incorrectas o no sabe hacerlas de manera óptima.
Tengo dos páginas de búsquedas con EPGSearch que ejecuta cada media hora y el equipo ni se colapsa ni se cuelga y funciona perfectamente y en todo este tiempo no he visto que tenga ningún problema en este sentido.

Un truco sería desactivar la EPG en los canales de TeleTienda (en modos EPG) para que el archivo de EPG ocupe menos y así la búsqueda sea más rápida cuando buscamos en todos los canales.
Otro es hacer grupos de canales en EPGSearch (son distintos a los grupos de canales del VDR) para acotar las búsquedas en esos canales y así no tiene que buscar en la EPG de todos los canales, es decir, crear un grupo de canales para el Fútbol que sólo contenga los canales que hechan fútbol, también para el cine, etc.
Si es un programa que siempre hechan en un canal concreto establecer en la búsqueda ese canal.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por jb el Lun 20 Jul 2009 - 10:08

Estoy de acuerdo con bittor, yo tengo programadas un montón de búsquedas, pero no las tengo asignadas a todos los canales, sino a canales concretos, y nunca me ha dado ningún problema.
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 47
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Posix el Lun 20 Jul 2009 - 13:19

Yo tengo un montón de búsquedas. Bueno unas 15. La mayoría libres (solo con la palabra/frase a buscar) y nunca he tenido ningún problema.

_________________
VDR-NG-EM 0.7 R1084 - WD Elements 1TB ext3
VDR-NG-EM 0.7 R1048 - WD Elements 250GB ext3
swap, samba, VPN, mediatomb, uShare, nfsd
avatar
Posix
Desarrollador

Cantidad de envíos : 691
Fecha de inscripción : 05/11/2008
Edad : 50
Localización : Madrid

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Videre el Lun 20 Jul 2009 - 22:04

No he llegado a probarlo, pero un familiar que también tiene nuestro equipo creó una búsqueda con una cadena vacía y dice que le creo miles de programaciones y se le quedó bastante bloqueado, algo que recuerda a lo que le pasó a Ciclope. ¿Es posible que no se valide que la cadena no sea cadena vacía? Sería interesante rechazar la búsqueda, porque no tiene sentido buscar todo, especialmente si se activa la grabación de cada programa encontrado.

_________________
Firmware VDR-NG-EM 0.7 Pro
Última revisión del SVN
avatar
Videre
Desarrollador

Cantidad de envíos : 391
Fecha de inscripción : 27/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por bittor el Mar 21 Jul 2009 - 10:05

Ya lo hace, si es menor de 3 caracteres te pregunta: "El texto a buscar es muy corto - ¿usar de todas formas?"
Tienes que confirmarlo para crear la programación.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Mar 21 Jul 2009 - 21:42

Videre escribió:No he llegado a probarlo, pero un familiar que también tiene nuestro equipo creó una búsqueda con una cadena vacía y dice que le creo miles de programaciones y se le quedó bastante bloqueado, algo que recuerda a lo que le pasó a Ciclope. ¿Es posible que no se valide que la cadena no sea cadena vacía? Sería interesante rechazar la búsqueda, porque no tiene sentido buscar todo, especialmente si se activa la grabación de cada programa encontrado.
En realidad es bastante fácil generar una búsqueda "maligna", que genere cientos de programaciones. Se le puede decir que no compare título, subtítulo ni descripción, y entonces, en lugar de no coincidir con nada, coincide con todo....(y no avisa). Y si encima no especificas el canal... Probablemente si se deja la cadena de búsqueda en blanco ocurre lo mismo.
A mi me ocurrió desarrollando el interfaz web, porque inicialmente tuve un desliz parecido y tampoco comprobaba que esos campos tuvieran un valor asignado. Generé una búsqueda que no buscaba nada y ...

Claro que aún no tengo la versión última, última del VDR puesta. Quizá esto está resuelto.

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Ciclope el Mar 21 Jul 2009 - 23:11

Bueno vale, la culpa es mía por haber utilizado mal el EPGSearch, pero como puse más arriba sólo hice dos busquedas por "4400" y por "BRICOMAN".
Me aparecieron los capítulos correspondientes y los seleccioné, comprobando más tarde que aparecían en Programaciones.
Lo que no entiendo es el motivo por el que se pusiera a grabar aleatoriamente de todos los canales y la duración también aleatoria de 2 a 180 minutos (si hubiera sido una busqueda mal programada no debería haber cortado alguna emisión).
Pero como no miré el "messages", nos quedaramos sin saber el motivo exacto.
Estudiaré mas a fondo este pluggin antes de volver a usarlo.

Ciclope

Cantidad de envíos : 21
Fecha de inscripción : 04/07/2009

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por yeahhh el Mar 21 Jul 2009 - 23:36

A ver, el plugin no tiene mucho secreto, yo he hecho varias búsquedas y no he tenido nunca problemas.
Solo he puesto el texto a buscar, donde quiero que lo busque, y el canal a buscar, en principio con eso es suficiente.
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 38
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Miér 22 Jul 2009 - 2:00

Si pones un texto para buscar pero le dices (por error) que no busque ni en el título, ni en el subtítulo ni en la descripción, no debería generar ninguna programación.
El hecho de que genere cientos de ellas es un defecto del epgsearch, no del usuario.

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por yeahhh el Miér 22 Jul 2009 - 8:29

Perfecto, pero sabiendo que el epgsearch tiene un defecto, hay que intentar no buscarle las cosquillas, ya que si no, el nos las buscará a nosotros Very Happy
avatar
yeahhh
Betatester

Cantidad de envíos : 2260
Fecha de inscripción : 18/08/2008
Edad : 38
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Jue 23 Jul 2009 - 3:27

Hombre, también está la opción de intentar arreglarlo, ¿no?. ;-)

Ésto es un esbozo de parche. Como aún no sé dónde se ponen los parches para los plugins, lo pongo aquí
por si alguien lo quiere usar (además así si el epgsearch contraataca... yo no he sido, ha sido otro... :P )

En el archivo menu_searchedit.c sale esta cosa (empieza en la línea 598) :
Código:

if ((data.useTitle || data.useSubtitle || data.useDescription) &&
      (int(strlen(data.search)) < 3) &&
      !Interface->Confirm(tr("Edit$Search text too short - use anyway?")))
      break;

Yo lo cambiaría por algo como:

Código:

if ((int(strlen(data.search))==0))
{
      Skins.Message(mtError, "¡Se te olvida buscar algo!");
      break;
}
if ((!data.useTitle && !data.useSubtitle && !data.useDescription))
{
      Skins.Message(mtError, "¡Se te olvida buscar en algún sitio!");
      break;
}
if ((int(strlen(data.search)) < 3) &&
      !Interface->Confirm(tr("Edit$Search text too short - use anyway?")))
    break;
Es absurdo permitir búsquedas de longitud 0 (por mucho que se confirme) y no veo
en qué caso tiene sentido aceptar que useTitle, useSubtitle y useDescription sean las tres
falsas (quizá existe alguno y se me escapa).

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por bittor el Jue 23 Jul 2009 - 11:59

Cuando actualice al último EPGSearch lo añado.
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Jue 23 Jul 2009 - 14:04

Hay un caso en el que sí tiene sentido que useTitle, useSubtitle y useDescripcion sean las tres falsas, y es cuando se busca en alguna de las categorías de la EPG extendida. Habría que estudiar la condición para evaluar si eso ocurre.

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por bittor el Jue 23 Jul 2009 - 17:19

Vaya, pues entonces ¿lo dejamos como está?
avatar
bittor
Desarrollador

Cantidad de envíos : 3629
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Vie 24 Jul 2009 - 2:58

Creo que el único caso en que el parche podría molestar sería el de alguien que utilizara exclusivamente la EPG "extendida" para hacer una búsqueda.

Dado que parece como si la mayoría de las cadenas emplearan chimpancés borrachos para rellenar la EPG "normal", quien hiciera eso estaría dando una muestra tal de audacia y valor, que sin duda merecería que descartáramos el parche en señal de respeto y admiración.

Pero ese espíritu valiente es hipotético y parece que somos un par ya los despistados reales que hemos puesto al equipo a intentar meter la televisión entera en el disco duro. Así que yo optaría por hacer el cambio.

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por jb el Vie 24 Jul 2009 - 9:17

No se si es factible que en la configuración del plugin cada uno pueda elegir si permitir esas búsquedas o no. Si se deja por defecto que no las permita, en el futuro, ese "hipotético valiente" podría tirarse a la piscina si quisiese.

Es una idea, si complica demasiado las cosas pues....a otra cosa mariposa.
avatar
jb
Betatester

Cantidad de envíos : 1192
Fecha de inscripción : 16/11/2008
Edad : 47
Localización : Lérida y Zaragoza

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por atinar el Sáb 25 Jul 2009 - 2:30

No creo que valga la pena hacerlo configurable; antes de eso vale más mirarse un poco mejor el código y hacer un parche que no tenga este problema.

Yo le tengo ganas al epgsearch por otra cosilla que me incordia más que ésta, así de paso que lo miro, quizá me vuelva a mirar ésto y si me aclaro mejor ya sugeriré otro parche. De momento si os parece que es mejor no cambiarlo, lo podemos dejar correr.

atinar
Desarrollador

Cantidad de envíos : 278
Fecha de inscripción : 06/09/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Harto del equipo

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.