Buscar
 
 

Resultados por:
 


Rechercher Búsqueda avanzada

Navegación
 Índice
 Wiki
 FAQ del foro
 FAQ del VDR-NG-EM
 Funcionalidades del VDR
 Mejoras del VDR-NG-EM
 Primeros pasos FW-VDR
 Descargas VDR-NG-EM
Flujo RSS


Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 



Generación del firmware incompleta

Página 3 de 3. Precedente  1, 2, 3

Ver el tema anterior Ver el tema siguiente Ir abajo

Re: Generación del firmware incompleta

Mensaje por luisfdez el Vie 26 Mar 2010 - 16:55

Bien. Ya tengo funcionando VDR en mi m750t. Usé la precompilación para Windows, no sin un susto durante los 4 enchufados, procedimiento que la primera vez no me funcionó (seguramente no lo hice bien).

Gracias de nuevo... ahora me toca aprender las peculiaridades y procedimientos de este sofware para sacarle más rendimiento.

Tenía el aparato en punto muerto al no haber renovado la sincroguía... no me hubiera importado pagar, pero en el período de pruebas me fue fatal, no se acoplaba a los cambios horarios de los programas... veía las series como redes tan sólo la primera mitad, ya que dedicaba la primera hora de grabación al final de la emisión que le antecedía.... ; bueno, qué no ya sabréis vosotros...

Estoy en deuda con vosotros y me gustaría mucho estar en disposición de poder serviros tan bien como me habéis servido a mí.

luisfdez

Cantidad de envíos : 8
Fecha de inscripción : 25/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por pjllaneras el Vie 26 Mar 2010 - 17:24

Ahora... a disfrutar del giga con VDR. Y mientras, vas probando la compilación en Linux, ya verás como poco a poco le pierdes el miedo , siguiendo los pasos que hay en el wiki es muy fácil (y ahora hay un script gráfico que lo simplifica aún más, sobre todo con Ubuntu).
avatar
pjllaneras
Betatester

Cantidad de envíos : 569
Fecha de inscripción : 29/01/2009
Edad : 44
Localización : Palma de Mallorca

Ver perfil de usuario

Volver arriba Ir abajo

Generación del firmware incompleta

Mensaje por jldelacruz el Mar 30 Mar 2010 - 14:27

Hola a todos,
Como es mi primer post en este fantástico foro, perdonarme si primero os cuento un poco mi vida (perdón por el rollo)
A finales de 2006 cometí el error de adquirir por un pastón el Siemens Gigaset M750T EPG con disco duro externo. Y digo "cometí el error" porque, como ya sabeís todos los que participáis en el foro, nadie me advirtió de las múltiples carencias y fallos del aparato y, lo que es peor, de que la Sincroguía sería de pago. La primera vez pagué la renovación de la dichosa Sincroguía pero cuando me volvió a caducar en febrero de 2010 me negué a pagar más a estos piratas de InOut. Así que me puse a buscar si se podía hacer algo y descubrí vuestro magnífico foro y el proyecto VDR de software libre, esto fue a finales de febrero primeros de marzo. Nada más leer los primeros pocos mensajes pensé ¡Eureka, esto promete ser la leche!. Me puse como un loco a leer y releer los FAQs y todos los mensajes más importantes hasta hacerme una idea cabal de lo compleja y completa que era vuestra solución: cambiar el firmware del equipo por uno mucho mejor. Siendo informático me parecía asumible la tarea de generar el firmware para Windows con vuestro asistente aunque hay muchísimos detalles que superan mis conocimientos, el caso es que con ayuda de vuestra guía de instalación del vdr (http://www.assembla.com/wiki/show/VDR-M7x0/Instalaci%C3%B3n_del_VDR-NG-EM) parecía muy fácil.
El caso es que mientras que a ratos sueltos me iba leyendo la información más relevante del foro fueron pasando los días y cuando finalmente me puse manos a la obra descubrí con pavor que había un nuevo tema, el "Generación del firmware incompleta", con el primer mensaje de bittor del 11-3 diciendo "Actualmente, no se puede generar nuestro firmware ni en Windows ni en Linux". ¡Vaya, que mala suerte!, ¡por unos pocos días!. Bueno, pensé, vamos a esperar un poco que seguro que encuentran alguna solución, total por unos días más..
Ayer por la tarde descubrí con gran alegría la entrada de luisfdez del 26-3 en que preguntaba "¿quiere decir eso que ya puedo realizar la instalación generando el sw con mi Windows Vista 32 bits?" y respuestas posteriores explicando que ya habiáis modificado lo necesario y que funcionaba. ¡Perfecto!.
Me bajé el fichero vdr-em-0[1].5-install-wizard.rar (de 2.803.607 bytes) y lo descomprií en mi PC con WXP Pro. Acto seguido ejecuté el comando generar-firmware-avanzado.cmd para poder ir viendo el progreso del invento. En la interface gráfica fui contestando a las opcines: M750T EPG, wsw y lite. Empezaron a aparecer líneas en el cmd. Las primeras fueron unas "download" (que tardaron casi una hora) y luego fueron apareciendo más, "tar...", "bin...", etc, todas ellas con algún error "No such file or directory", "...the input file 'bla,bla' is empty", etc. La interface gráfica me preguntó por el directorio de grabaciones y dejé por defecto "media/disk-volume-0". Unos cuantos errores más y salió una ventana con el aviso "¡Descarga completada!" Ya puedes instalar el firm en tu equipo mediante el menú de los 4 enchufazos". Por supuesto no hay ni rastro del fichero .wsw.
Tengo que añadir que, como hago todo esto en el PC del trabajo, estamos detrás de un firewall y otras medidas de seguridad por lo que quizás se pueda estar bloqueando el acceso a determinadas direcciones.
Mi pregunta es: ¿de verdad está arreglado del todo el fichero vdr-em-0[1].5-install-wizard.rar? ¿se puede generar un .wsw para Windows? ¿o es algún problema específico de mi situación?
Muchísimas gracias por adelantado a cualquier ayuda que me podáis prestar.


Última edición por Krako el Mar 30 Mar 2010 - 20:48, editado 1 vez (Razón : Delete Size 9 ;))

jldelacruz

Cantidad de envíos : 8
Fecha de inscripción : 30/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por pjllaneras el Mar 30 Mar 2010 - 18:58

No sé si os pasará a vosotros, pero yo de golpe necesito gafas para leer .

Bienvenido al foro jldelacruz!!! a ver si puedes editar el mensaje y poner una fuente más normal... me he tenido que sacar los ojos para leerlo.

Sobre tus dudas, en principio los problemas están resueltos, aunque yo no uso windows en casa, sólo Linux, por lo que no sabría decirte si ha aparecido alguno nuevo en la versión Windows (a ver si luego pruebo la de Linux y me aseguro que va bien)... lo suyo es que revises el último error que te ha dado el proceso, a lo mejor te da pistas de por donde está el problema, y si no, lo pones por aquí, seguro que te podremos ayudar.
avatar
pjllaneras
Betatester

Cantidad de envíos : 569
Fecha de inscripción : 29/01/2009
Edad : 44
Localización : Palma de Mallorca

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por Krako el Mar 30 Mar 2010 - 21:00

pjllaneras escribió:No sé si os pasará a vosotros, pero yo de golpe necesito gafas para leer .
pjilaneras @ Ya no necesitas las gafas

jldelacruz @ Bienvenido al foro, al ser informático yo me atrevería a poner el Virtualbox con Ubuntu y
trastear con la última release del firm (it's easy).

Referente al tema de los errores en la generación del firmware, muchos de estos son debidos a que los links de los diferentes paquetes que son necesarios para compilarlos ya no están disponibles. Como bien te comenta el compañero pjilaneras, revisa los logs y pega el error que estaremos encantados de ayudarte a solucionar el problema.

Salu2,

_________________

M740: VDR-NG-EM 0.7 Pro (Última revisión) + Plugins
LAN 100Mbits + HDD USB WDElements 640Gb (3*ext2)

Wiki Foro Download
avatar
Krako
Moderador

Cantidad de envíos : 415
Fecha de inscripción : 25/06/2008
Localización : Barcelona

Ver perfil de usuario

Volver arriba Ir abajo

Generación del firmware incompleta

Mensaje por jldelacruz el Miér 7 Abr 2010 - 15:59

Hola de nuevo,

Antes que nada, por favor perdonarme por la fuente con la que salió mi primer mensaje, error de principiante. Es que escribí el texto en el Notepad y luego lo copié y quedó como quedó. Gracias Krako por corregir mi metedura de pata.

Y en segundo lugar, solicitar excusas por la "expantá". Resulta que posteé el 30-3 y luego llegaron las vacaciones de Semana Santa y hasta hoy.

Bueno, vamos al tema. La sugerencia de Krako de trabajar en entorno Linux no es aplicable pues no utilizo NADA de Unix desde hace más de 12 años y, sinceramente, tendría que dedicar varios días a los trabajos previos; me parece más rápido intentar conseguir el firm desde Windows y pasar página, después de todo la Guía paso a paso que teneís publicada lo hace parecer tan fácil ...

En fin, el caso es que acabo de volver a ejecutar el comando generar-firmware-avanzado.cmd y he guardado todos los mensajes que han ido apareciendo en el fichero LOG100407.TXT que os adjunto con la esperanza de que os facilite alguna pista de lo que pueda estar pasando. En la ventana gráfica se me ha preguntado y he ido marcando:
a) hardware: M750T EPG
b) tipo de firmware: wsw
c) version: lite
d) directorio de grabaciones: media/disk-volume-0
y salió: ¡descarga completada!

Más datos: estoy trabajando en un PC con WXP Pro con todos los parches al día. Estoy en la oficina, la salida a Internet es vía proxy con autenticación de usuario y existen medidas de seguridad como firewall, etc sobre las que no puedo aportaros detalles porque los desconozco (mi hipótesis es que algo en mi empresa puede estar bloqueando las descargars de drivers y demás que intenta realizar el script CMD).

Lo dicho, cualquier ayuda que me podáis prestar será muy apreciada. Saludos a todos y gracias de antemano.

jldelacruz

Cantidad de envíos : 8
Fecha de inscripción : 30/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Generacion del firmware incompleta

Mensaje por jldelacruz el Miér 7 Abr 2010 - 16:02

Sorry, olvidé incorporar el log con los textos. Aquí va, es el fichero LOG100407.TXT
Archivos
LOG100407.TXT No tienes los permisos para descargar los archivos.(5 KB) Descargado 4 veces

jldelacruz

Cantidad de envíos : 8
Fecha de inscripción : 30/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por bittor el Miér 7 Abr 2010 - 18:52

Tienes un problema al bajar los archivos y supongo que tienes el directorio downloads vacío.

Prueba a borrar todo lo que haya dentro del directorio temp (si hay algo) y baja estos archivos manualmente y mételos en el directorio downloads:
http://gigaset.com/medias/sys_master/Gigaset_M740_AV_V_2.4.exe
http://subversion.assembla.com/svn/VDR-EM-NG_Test/o7o_flasher
http://subversion.assembla.com/svn/VDR-EM-NG_Test/siemens-linux-kernel-m740_lite.img
http://subversion.assembla.com/svn/VDR-EM-NG_Test/rootfs_dir_m740_lite.tgz
http://subversion.assembla.com/svn/VDR-EM-NG_Test/file_tab.rootfs_dir_m740_lite.lst

Después ejecuta (en el mismo dir que está el cmd):
bin\unzip -d downloads downloads/Gigaset_M740_AV_V_2.4.exe

Cuando ejecutes el cmd y te pregunte si quieres borrar los archivos bajados anteriormente dile que no.
avatar
bittor
Desarrollador

Cantidad de envíos : 3630
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por jldelacruz el Miér 14 Abr 2010 - 18:45

Muchas gracias Bittor por tu contestación del 7-4 (y perdón por la infrecuencia de mis mensajes, es que apenas tengo tiempo). Acertaste plenamente, mi directorio /downloads estaba vacío. Me bajé los archivos que me decías y (tras un pequeño percance, el fichero file_tab.rootfs_dir_m740_lite.lst se me había almacenado con el nombre file_tab.rootfs_dir_m740_lite.lst.txt) pude por fin conseguir el ansiado fichero wsw.
El lunes 12-4 me lo llevé a casa en un pendrive y lo instalé siguiendo vuestras instrucciones. En unos pocos minutos ya estaba viendo la TV perfectamente (incluso veía La Sexta que antes no podía ver -vivo en Madrid- con la mierda del firm de Siemens).
Tengo que pulir varios detalles pero no quiero haceros perder el tiempo exponiéndolos aquí, antes repasaré los hilos del foro por si estuvieran ya contestados en algún sitio.
Eso sí, tengo un problema bastante gordo que necesitaría resolver urgentemente antes de que me maten mi mujer y mis niños. Resulta que el Gigaset se nos apaga, bueno, más bien se nos muere, y no hay forma de resucitarlo. He intentado todo lo que comentáis incluyendo la combinación de teclas Menu+0+8+3+7 y Menu+0+6+7+9 pero como si nada. Solo he conseguido volver a encender el Gigaset recurriendo a los 4 enchufazos, opción "factory reset" y opción "reboot"; entonces si que vuelve a arrancar con el propio firm VDR y se ve por fin la TV pero no es plan de hacer esto cada vez que queremos ver la tele. Os agradecería que me dierais alguna pista de por qué se me apaga totalmente el Gigaset, ¿qué estoy haciendo mal?. ¿que configuración tengo que tocar para que no me pase esto?
Antes, con el firm de Gigaset, el aparato NO se apagaba nunca lo que era un despropósito pero ahora se queda M-U-E-R-T-O del todo, tiene que haber un término medio ¿verdad?

jldelacruz

Cantidad de envíos : 8
Fecha de inscripción : 30/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por zjuanma el Miér 14 Abr 2010 - 23:38

empieza desactivando los plugins, y luego ves activandolos 1 a 1 por si es algun plugin que no vaya bien.

_________________
M740AV + VDR-NG-EM 0.5 - SVN EM 759 - SVN TC - o7o 410 - SVN plugins 744
Disco: Western Digital Elements mediante un NAS
Conectado a Internet
Plugin yaep 0.2.1: http://sites.google.com/site/yaepvdr
avatar
zjuanma
Desarrollador

Cantidad de envíos : 818
Fecha de inscripción : 27/06/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por bittor el Jue 15 Abr 2010 - 9:16

Si tienes la versión Pro, accede por FTP al giga y cuelga aquí el archivo /var/log/messages
Si tienes la versión Lite, tendrás que activar el log como se explica aquí y copiar el archivo /var/log/messages a un stick con el plugin FileBrowser (tendrás que activarlo en la configuración -> Gestión de plugins) para colgarlo en el foro.
avatar
bittor
Desarrollador

Cantidad de envíos : 3630
Fecha de inscripción : 25/06/2008
Localización : Zaragoza

Ver perfil de usuario http://bittor7x0.googlepages.com

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por jldelacruz el Jue 15 Abr 2010 - 13:54

Zjuanma, Bittor: muchas gracias por vuestro interés.
Repasando el foro (jo, hay tantos hilos que se tarda un montón en aprender todo lo que ya está resuelto) descubrí una solución que me funciona.
Como ya sabéis vosotros, en la Configuración hay un setting que es el Tiempo de inactividad, venía por defecto en 180 (minutos), lo puse en 0 y al menos he conseguido que no se me apague. No será la solución óptima, por supuesto, pero he salvado el "set-ball", ya con tiempo iré buscando qué debo modificar para que se me apague el Gigaset (y así ahorrar energía) pero que no se me muera del todo.
En resumen, por mi parte, cierro este hilo y dejo constancia: funcionó bien la compilación en windows (bajando previamente la lista de ficheros proporcionada por bittor) y funcionó bien la instalación del firmware en el Gigaset. El problema de que se me "moría" el equipo se solucionó poniendo 0 en el parámetro Tiempo de inactividad.
Ahora me toca conseguir que el disco duro se vea pero esto ya lo postearé en otro hilo, ya he visto que en "Problemas encontrados" hay varios al respecto y me iré allí a daros la lata un poco.
Muhas gracias por todo.

jldelacruz

Cantidad de envíos : 8
Fecha de inscripción : 30/03/2010

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por pjllaneras el Jue 15 Abr 2010 - 18:45

Este parámetro sirve para que al cabo de x minutos de inactividad (esto quiere decir, que nadie toca el mando a distancia) se para el giga... creo que lo mejor es que actives el apagado rápido.

Con el apagado rápido el Giga realmente no se apaga y evitas que pulsando el botón de "encendido" del mando el giga se apague (el parámetro que has cambiado no lo evitará). Para configurar el apagado rápido debes cambiar el valor de la opción en:

Configuración - Configuración VDR - DVB - Apagado rápido
avatar
pjllaneras
Betatester

Cantidad de envíos : 569
Fecha de inscripción : 29/01/2009
Edad : 44
Localización : Palma de Mallorca

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por amolinam el Lun 4 Ene 2016 - 18:08

Creo que este tema ha vuelto a suceder. Creo que Siemens ha eliminado los archivos que necesitamos para generar el fw. Sad

amolinam

Cantidad de envíos : 7
Fecha de inscripción : 04/01/2016

Ver perfil de usuario

Volver arriba Ir abajo

Re: Generación del firmware incompleta

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Página 3 de 3. Precedente  1, 2, 3

Ver el tema anterior Ver el tema siguiente Volver arriba


 
Permisos de este foro:
No puedes responder a temas en este foro.